Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
PowerView Patch for PM820 Energy Logging Issue

Issue
The hourly energy of PM820 is incorrectly shown on Report of PowerView 2.01. However there is no problem for PM850 and PM870.

Product Line
PowerView 2.01 (Legacy)

Environment
Reporting in PowerView 2.01

Cause

It i found that there is no data on hourly report of PowerView for PM820. However, there is no problem on PM850 and PM870. For PowerView version 2.01, there is a problem on retrieval of the hourly energy logging of PM820. The PM820 has a log that involves billing values, including Real Energy. This billing log is a single file on the device, but is separated into three different files via software. The files are "hour by hour", "day by day", and "month by month."
The issue regarding PowerView v2.01 is that the file being read is the "day by day" and not the "hour by hour" log. This results in the meter uploading just one record a day, and then when the customer generates a report the software interpolates the "hour by hour" values from the "day by day" values. The interpolation results in the "hour by hour" values being almost identical.

Resolution
The change needed to correct this issue is to modify the stored procedure and file that uploads data from PM820 series meters and their onboard logs. This is done with an executable file downloaded to the machine with PowerView installed. This is language independent and will work with all versions of PowerView.

Please refer to the attached patch file to fix the problem.


Legacy KB System (APS) Data: RESL201820 V1.0,
Related ranges: PM800 series, PowerView

Schneider Electric Hong Kong

Attachment(s)
Patch_File_for_PM820_Energy_Logging_and_PLNS_Fixing.zip [49.97 KB]
Explore more
Range:
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range:

Need help?

  • Start here!

    Find answers now. Search for a solution on your own, or connect with one of our experts.

  • Contact Support

    Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.

  • Where to buy?

    Easily find the nearest Schneider Electric distributor in your location.

  • Search FAQs

    Search topic-related frequently asked questions to find answers you need.

  • Contact Sales

    Start your sales enquiry online and an expert will connect with you.

I'd like to receive news and commercial info from Schneider Electric and its affiliates via electronic communication means such as email, and I agree to the collection of information on the opening and clicks on these emails (using invisible pixels in the images), to measure performance of Schneider Electric's communications and to improve them. For more details, please read our Privacy Policy.

  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact centre
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Careers
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Newsroom
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings