Our Brands

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
Cannot SSH to PowerChute Network Shutdown virtual machine.

Issue:

The user cannot SSH to the PowerChute Network Shutdown virtual machine.

Product:

PowerChute Network Shutdown 4.x, 5.x

Environment:

PowerChute Network Shutdown Linux virtual machine.

Cause:

The SSH service is set incorrectly on the Linux virtual machine.

Solution:

1- Log into the virtual machine and verify that SSH is active

Run the command systemctl status sshd

If the system reports that sshd is disabled or inactive, enter the command systemctl start sshd

disabled ssh service

SSH service inactive

Start SSH service

2- After verifying that the service is running, when connecting, an error is posted stating access is denied or authentication failed, run the commands listed below to permit the root user SSH access.

Access denied while using Putty

Access denied while using Filezilla

For PowerChute VM versions 4.x, 5.0, and 5.1, run the commands:

cp /etc/ssh/sshd_config /etc/ssh/sshd_savedconfig (This command will make a copy of the original sshd_config file.)

echo "PermitRootLogin yes" >> /etc/ssh/sshd_config (This command will add a new line to the sshd_config file permitting root login.)

systemctl restart sshd (This command will restart the sshd service.)

For PowerChute VM versions 5.2 and above, run the commands:

cp /etc/ssh/sshd_config.d/00* /etc/ssh/sshd_config.d/SavedConfig.txt (This command will make a copy of the original 00-complianceascode-hardening.conf file.)

sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/ssh/sshd_config.d/00* (This command will edit the root log in permissions to allow root to log in over SSH/SFTP.)

systemctl restart sshd (This command will restart the sshd service.)

NOTE: We recommend disabling SSH access when not required.

Schneider Electric Hong Kong

Cannot SSH to PowerChute Network Shutdown virtual machine.

Issue:

The user cannot SSH to the PowerChute Network Shutdown virtual machine.

 

Product:

PowerChute Network Shutdown 4.x, 5.x

 

Environment:

PowerChute Network Shutdown Linux virtual machine.

 

Cause:

The SSH service is set incorrectly on the Linux virtual machine.

 

Solution:

1- Log into the virtual machine and verify that SSH is active

Run the command systemctl status sshd

If the system reports that sshd is disabled or inactive, enter the command systemctl start sshd

disabled ssh service

SSH service inactive

Start SSH service

2- After verifying that the service is running, when connecting, an error is posted stating access is denied or authentication failed, run the commands listed below to permit the root user SSH access.

Access denied while using Putty

Access denied while using Filezilla

For PowerChute VM versions 4.x, 5.0, and 5.1, run the commands:

cp /etc/ssh/sshd_config /etc/ssh/sshd_savedconfig (This command will make a copy of the original sshd_config file.)

echo "PermitRootLogin yes" >> /etc/ssh/sshd_config (This command will add a new line to the sshd_config file permitting root login.)

systemctl restart sshd (This command will restart the sshd service.)

 

For PowerChute VM versions 5.2 and above, run the commands:

cp /etc/ssh/sshd_config.d/00* /etc/ssh/sshd_config.d/SavedConfig.txt (This command will make a copy of the original 00-complianceascode-hardening.conf file.)

sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/ssh/sshd_config.d/00* (This command will edit the root log in permissions to allow root to log in over SSH/SFTP.)

systemctl restart sshd (This command will restart the sshd service.)

 

NOTE: We recommend disabling SSH access when not required.

Schneider Electric Hong Kong

Explore more
Range:
Explore more
Range:
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range:
Explore more
Range:

Need help?

  • Start here!

    Find answers now. Search for a solution on your own, or connect with one of our experts.

  • Contact Support

    Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.

  • Where to buy?

    Easily find the nearest Schneider Electric distributor in your location.

  • Search FAQs

    Search topic-related frequently asked questions to find answers you need.

  • Contact Sales

    Start your sales enquiry online and an expert will connect with you.

I'd like to receive news and commercial info from Schneider Electric and its affiliates via electronic communication means such as email, and I agree to the collection of information on the opening and clicks on these emails (using invisible pixels in the images), to measure performance of Schneider Electric's communications and to improve them. For more details, please read our Privacy Policy.

  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact centre
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Careers
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Newsroom
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings
Your browser is out of date and has known security issues.

It also may not display all features of this website or other websites.

Please upgrade your browser to access all of the features of this website.

Latest version for Google Chrome, Mozilla Firefox or Microsoft Edgeis recommended for optimal functionality.