Issue
Opening data log viewers on device diagrams take a very long time to load, or eventually show "there was a problem processing your request".
Product Line
Power Monitoring Expert 7.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Diagrams
Vista
Cause
Data log viewers on the default device diagrams are configured to load all historical records for the source/measurement pairs selected in the data log viewer. If the source has been recording for a long time, the log can take a long time to load or load unsuccessfully due to the high quantity of records.
Resolution
Configure the data log viewer to load only the past 90 days of records instead.
1. In the PME Web Applications Diagrams tab, open a device diagram where this issue is occurring. Locate the diagram file that needs to be edited by hovering the mouse over the Logs button. This will display a small banner that contains the name of the diagram file. In the following example, it's the 8000_FAC-PQ-61850-4WYE_V1.0.1-logs.dgm file:
2. On the PME server, log into Vista and go to File > Open
3. Navigate to the "default" folder and locate the folder corresponding to the diagram file name. Make a copy of the "-logs.dgm" file inside this folder to serve as a backup, then open the file:
4. Right-click on the log that takes long to load or is showing an error message, then go to Query tab > Edit SQL. Scroll to the bottom of the Notepad file and paste the following text on the line above the "ORDER BY" clause:
WHERE timestamp >= last_quarter_to_date()
5. File > Save the Notepad file, then click OK to close the data log viewer configuration window.
6. File > Save the diagram in Vista.
Note: It is important to open and edit the device diagrams files directly from the ...\config\diagrams\ud\default folder, with no device selected on the diagram. Making these changes while on a specific device's diagram will cause a misleading node link on the data logs, causing each device of the same type to load one device's historical data instead of that device's own data. You can verify this while editing by making sure there is no device name shown at the top of the diagram, and the data log viewer configuration window has "Use parent node" grayed out:
Released for: Schneider Electric Hong Kong
Need help?
- Product Selector- Quickly and easily find the right products and accessories for your applications. 
- Get a Quote- Start your sales enquiry online and an expert will connect with you. 
- Where to buy?- Easily find the nearest Schneider Electric distributor in your location. 
- Help Centre- Find support resources for all your needs, in one place.