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Cannot login to PME Web with error User is Not Licensed
Issue
The following error occurs when the user tries to login into PME Web:

screenshot of error

Access denied. This user is not licensed for web access.

Product Line
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment
PME Web Application

Cause
PME web licenses are assigned to users as they log in. If a user is deleted after having a license assigned to it, the SQL database may take time to register the change. If the maximum number of web licenses had previously been reached this means new users that are created will not be able to be licensed as the number of users exceeds the number of available web licenses.

Resolution
The assigned license can be manually freed in the SQL database. In order to achieve this run the following script:

delete FROM [ION_Network].[dbo].[GroupMembershipMap] where TrusteeID NOT IN (SELECT UserID FROM  [ION_Network].[dbo].[Users])

For convenience the script is attached to this article.

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Attachment(s)
script.sql [126 Bytes]
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