How to perform basic communications troubleshooting for PowerLogic meters and gateways
Issue
How do I perform basic communications troubleshooting steps on Powerlogic devices with Modbus communications?
Product Line
Powerlogic devices
CM2000, CM3000, CM4000, PM800, PM700, PM5000
EGX-100, 200, 300, 400
Environment
Energy monitoring
Cause
A PowerLogic device is experiencing communications problems and will require troubleshooting.
Resolution
1. If using an EGX or ECC card
Ping the EGX/ECC card IP address
If unable to ping: How to determine the IP address
If able to ping: Access the Webpage and write down the communication parameters (Baud rate, parity).
2. Check device list on the webpage and make sure that the device that is not communicating is in the list with the correct Device ID
3. Check DIP switches on the EGX/ECC card (see EGX/ECC installation manual )
4. Check the baud rate and parity on the serial device and make sure it matches the settings on the gateway
5. Check Device ID and make sure there are no duplicate IDs in the serial chain
6. Check Device wiring. The wiring from the master to first slave device follows: transmit goes to receive, receive goes to transmit.
7. Are wires installed to the serial port and not some other port such as the Digital input or KYZ pulsing if available?
8. At any point were wires other than communications wiring applied to the serial port?
9. Check the communication port and make sure that the Transmit ports measures around 5 volts. If the meter does not read any voltage then make sure the connector is plug in correctly. If it is, then the port might be damaged and the meter needs to be replace
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