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Power Monitoring Expert - when I try to generate any report, there is an error in the UI saying 'An error occurred while generating the report. Please see your system administrator'

Issue
When trying to generate a report there is an error in the browser. In the EventException table in the ION_SystemLog the following error can be seen:

An error has occurred during report processing. ---> System.Globalization.CultureNotFoundException: Culture is not supported.  Parameter name: culture  4096 (0x1000) is an invalid culture identifier.

Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Power Monitoring Expert 2020

Environment
The Region selected in Settings has been set to a custom culture, such as francais (Tunisie) or English (Sweden).

Cause
There is a known issue with the Microsoft Report Viewer control and custom cultures. See this link for more information:

https://social.msdn.microsoft.com/Forums/vstudio/en-US/671bc463-932d-4a9e-bba1-3e5898b9100d/culture-4096-0x1000-is-an-invalid-culture-identifier-culturenotfoundexception?forum=csharpgeneral

Resolution
Change the Region to something different to workaround this problem.

Schneider Electric New Zealand

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