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Power Monitoring Expert 9.0 - Enable JavaScript Error in Web Applications

Published date: 27 March 2020

Issue
When navigating to the Power Monitoring Expert Web Applications, the login field does not display and the following error is shown:

"The login cannot proceed because JavaScript is not fully enabled in the browser. Enable Javascript and try starting the Web Applications again."



Product Line
Power Monitoring Expert 9.0

Environment
Web Applications

Cause 1 
Power Monitoring Expert 9.0 comes installed with HTTPS enabled and configured using a Self Signed Certificate during installation. However, certificates are generally rejected by most browsers, therefore, a user may opt to install a certificate from a Certificate Authority. This certificate is tied to a fully qualified domain name rather than just the server name (i.e. https://mypmeserver.mydomain.com) whereas PME by default is set up just to use the server name (i.e. https://mypmeserver/). This mismatch between the fully qualified domain name of the SSL certificate and the server name configured in the PME databases is what causes the JavaScript error. 

Cause 2
You see the following error message in the ApplicationModules Diagnostics.

"A problem occurred on page 'https://mypmeserver.mydomain.com/SystemDataService/sharedcontent/map': Could not load file or assembly 'WebGrease, Version=1.5.2.14234, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)"


Resolution 1
In order for the Web Applications to work, there are two locations in the PME databases that need to be updated with the fully qualified domain name. 

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

Application Modules database update

1. Open SQL Server Management Studio and connect to the PME instance. 
2. Navigate to Databases -> ApplicationModules -> Views
3. Right-click on Configuration.ConfigurationSettings and select Edit Top 200 Rows 4.
4. Find the entry in the result set with the following values:

- ItemType = Web Framework
- Item = Server
- Key = LocalServerAddress 

5. Update the Value column so that the value matches the fully qualified domain name that is listed in the SSL certificate (i.e. https://mypmeserver.mydomain.com)

ION_Network database update

1. Navigate to Databases -> ION_Network -> Views
2. Right-click on dbo.vCFG_ConfigItems and select Edit Top 200 Rows
3. Find the entry in the result set with the following values:

-Module = Reporting
-Category = General Settings
-Item = WebServiceUrl

4. Update the Value column so that the value includes the fully qualified domain name that is listed in the SSL certificate. (i.e. https://mypmeserver.mydomain.com/ionreportdataservice/ReportDataService.asmx)
5. Once the two database fields have been updated, close SQL Server Management Studio, restart the four ION Application Modules services and restart IIS. 

Resolution 2

(ONLY if the issue explained in cause 2 is observed)


Replace all instances of the string "1.5.2.14234" with "1.6.5135.21930" in all the web.config files.
 
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\AlarmConfiguration\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Alarms\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\ApplicationFramework\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Dashboards\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Diagrams\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\HierarchyManager\web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\HierarchyManager\web.config.TestAuto (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\ModelingConfig\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Slideshow\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\SystemDataService\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Teams\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\applications\Trends\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\WebReach\Web.config (2 hits)
  C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\web\Web.config (2 hits)

Restart the four ION Application Modules services and restart IIS. 
If this does not resolve all issues, a reconfiguration of the system is recommended if it has not been done yet. 

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