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Hierarchy Manager Fails to Upload Records

Issue
When changing tabs in Hierarchy Manager, the system tries to upload records. However, after a few minutes, it fails and shows the following message:

Hierarchy message from webpage
Loading records...
Failed to load data from the server. Please try again.

Product Line
Power Monitoring Expert 9.0

Environment
Hierarchy Manager

Cause
By default, the hierarchy manager has to upload records within 2 minutes. If it doesn't manage to upload within this time, it will fail.

Resolution
Change the Javascript file for HierarchyManager to increase the timeout. The file is:

...\Power Monitoring Expert\applications\HierarchyManager\Scripts\HierarchyManager\data.nodemodel.js

Find the following code snippet:

$.ajax({
type: "GET",
url: baseUrl,
timeout: 2*60*1000, // 2 minutes. Some hierarchy pages can take a long time to generate.
data: { nodeQuery: JSON.stringify(nodeQuery) },
dataType: "json",
success: onSuccess,
error: onError,
page: page
});

Change the timeout to 4*60*1000. This increases the timeout to 4 minutes.

*Note: This solution does not apply to versions of PME after PME 9.0

Schneider Electric New Zealand

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