我們的品牌

Impact-Company-Logo-English Black-01-177x54

歡迎造訪施耐德電機全球網站

歡迎訪問我們的網站
		
我们今天能为您提供什么帮助?
Power Monitoring Expert - Vista error "Query timeout expired"

Issue
Customer receives the following error when attempting to view a Datalog viewer in Vista: "Query timeout expired"

Product Line
ION Enterprise 5.x
ION Enterprise 6.x
Struxureware Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x

Environment
Vista

Cause
There is a difference between on how Vista and WebReach execute a query of a data/waveform/event recorder. In WebReach there is timestamp filter. This filter will only return data for the specified range consequently the query runs fast. In Vista it will query the entire DB for that one meter; if the ION_Data database size is large the query may time out.

When a query runs in Vista the following error messages are displayed.

Image 1

Image 2


Resolution
In order to increase the timeout period of a Vista query, a new entry to the server's registry needs to be added such that the Query server connect timeout is increased.

*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*

Resolution A.  Increase the Vista query timeout

  1. Select Start > Run then type regedit in the Run window to open the registry
  2. Within the registry, navigate to the following path depending on your version of PME:
HKEY_LOCAL_MACHINE\SOFTWARE\Power Measurement\ION Enterprise\5.5
HKEY_LOCAL_MACHINE\SOFTWARE\Schneider Electric\ION Enterprise\5.6
HKEY_LOCAL_MACHINE\SOFTWARE\Schneider Electric\ION Enterprise\6.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\6.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\7.0.1
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\7.2.2
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.1
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.2
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\9.0
  1. Right click in the right hand pane and select New > DWORD Value
  2. Name the new DWORD: VistaQueryTimeout_s
  3. Right click on VistaQueryTimeout_s and select Modify
  4. Enter a new value for the timeout period.  The timeout period is 60s by default so its is recommendable to doubling its value to 120s (120 decimal) if this is not enough increase it to 180
  5. Select File > Exit to exit the registry editor

If the system include client machines running Vista this change need to be performed into the client's machine registry as well.

Resolution B.  Increase the Query server timeout

  1. Open the Query Server node in Designer.
  2. Open the properties for the Query module.
  3. Modify the Connect_Timeout from the default 60 to 120 (or 180 if it is necessary).
  4. Save this setting and restart the Query Server Service

施耐德電機Taiwan

探索更多
系列:
探索更多
系列:

需要協助?

  • 產品選型工具

    快速輕鬆地為您的應用找到合適的產品和附件。

  • 取得報價

    立即線上提交您的銷售需求,專業團隊將主動聯繫您。

  • 購買地點

    輕鬆在您所在地區找到最近的施耐德電機經銷商。

  • 支援中心

    在同一位置找到滿足您所有需求的支援資源。

  • 產品文檔
  • 軟體下載
  • 產品選型工具
  • 產品替代和替換
  • 幫助和聯絡中心
  • 尋找我們的辦公室
  • 取得報價
  • 人才招募
  • 公司簡介
  • 舉報不當行為
  • 無障礙
  • 新聞中心
  • 投資者
  • 專業洞察
  • 台灣施耐德電機學院
  • 綠色影響力落差調查
  • Schneider Go Green 2025
  • 隱私政策
  • Cookie通告
  • 使用條款
  • Change your cookie settings