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ION meter data logs are very slow to upload

Issue
Data logs from ION meters are very slow to upload into the ION Enterprise / SPM / PME software.

For devices experiencing this issue the most recent logged data in the database may be several days old even though there is no apparent communication issue with the device.

Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024

Environment
Power Monitoring Software

Cause
One possible cause of this issue can happen after deleting register names from ION meter modules in the ION Designer.

In Management Console, access the Diagnostics Viewer Log Performance tab, look at the information for the device that is experiencing this issue, you will see that the event log contains many pending records. The Event Log is always LogHandle 0x1000
Management Console

Diagnostic Viewer

In the Designer application, it is possible to delete the register labels for a module and send those changes to the meter. In the example below the label for Output Register 6 has been deleted.

ION Setup


When this occurs an event will get logged in the meter's event log with the handle value instead of the label name.

Event Log

Once this happens, the loginserter service will not be able to process the event and the previous event will be the last event logged in the database.

Since there is a high priority on capturing a meter's event log, the other logs on the device may lag behind as the loginserter service is hanging up on the event log.

Cause 2

Another potential issue is that messages are still filtering into the database via the Microsoft Message Queues. Logged data must filter from the device to the log subsystem router where it is processed via the Microsoft Message Queues. When large amounts of data is incoming to the PME server, there may be throttling of the message queueing which slows down the processing of data. This can happen when many devices are switched on at once or a large amount of data is coming into the database all at once.

You can check the status of the queue by navigating to Computer Management -> Services and Applications -> Message Queueing. Click on Private Queues. The below is what the queue should look like if data has been filtered into the database properly.

Message Queueing



Resolution
In order to resolve this issue, you will need to clear the meter's event log.

This can be done in ION Setup by modifying a Setup Register in the device's Event Log Control Module which will reset the logged events. You can then revert the change.

Example: Set the Depth to 0 and send the changes then set the depth back to its previous value and send the changes again. The same procedure can be carried out in Designer.


Event Log Configuration


Resetting the Event log will allow the software to begin uploading the Event log successfully.

It is also suggested to add a register label to the module registers that do not have a name.


Resolution 2

If the queue is full, and begins throttling, users may restart the ION Log Subsystem
Router Service to restart the sorting process from the message queues into the proper tables in the ION_Data database.


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