我們的品牌

Impact-Company-Logo-English Black-01-177x54

歡迎造訪施耐德電機全球網站

歡迎訪問我們的網站
		
我们今天能为您提供什么帮助?
Power Monitoring Expert Diagnostics Viewer displays "Could not load file or assembly 'ADODB, Version=7.0.3300.0"
Issue
When attempting to open the Diagnostic Viewer, the following message is displayed "could not load file or assembly 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b0315f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference HRESULT: 0x80131040". The error in Diagnostic Viewer looks like image shown below:




Product Line
Struxureware Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x

Environment
Diagnostic Viewer

Cause
Occurs in a distributed system when the wrong version of adodb.dll is placed in the Power Monitoring Expert/system/bin directory.

Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).*

1. On the database server, navigate to the C:\Program Files (x86)\Microsoft .NET\Primary Interop Assemblies\ folder
2. Copy the adodb.dll file
3. On the Database server, navigate to the Power Monitoring Expert\system\bin folder and back up the existing adodb.dll file already present. Then, place the adodb.dll file from step 1 into this folder.
4. Next, navigate to Power Monitoring Expert\system\bin folder on the Application Server and back up the existing adodb.dll file already present. Then, place the adodb.dll file from step 1 into this folder.

施耐德電機Taiwan

探索更多
系列:
探索更多
系列:
  • 產品文檔
  • 軟體下載
  • 產品選型工具
  • 產品替代和替換
  • 幫助和聯絡中心
  • 尋找我們的辦公室
  • 取得報價
  • 施耐德電機社群
  • 人才招募
  • 公司簡介
  • 舉報不當行為
  • 無障礙
  • 新聞中心
  • 投資者
  • 專業洞察
  • 台灣施耐德電機學院
  • 綠色影響力落差調查
  • Schneider Go Green 2025
  • 隱私政策
  • Cookie通告
  • 使用條款
  • Change your cookie settings