Power Monitoring Expert - When doing a standalone PME install, the PME installer is unable to find an existing SQL instance and wants to install SQL Express
Issue
When trying to install Power Monitoring Expert 8.x/9.0 on a standalone server on which SQL Server has already been installed, the PME installer is not able to find this existing SQL Server instance and the only option given is to install SQL Express. SQL Server is clearly installed, and the SQL Server and SQL Browser services are both running.
Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Environment
A new PME install on a standalone server. SQL Server has already been installed as per the System Guide.
Cause
The PME installer queries the system to find a list of existing SQL Server instances. It imposes a 100 second timeout. If it takes longer than 100 seconds to obtain this list of SQL Server instances, the installer will advance to the screen that tells the user no SQL Server instances were found and offers to install SQL Server Express. This timeout setting is contained in one of the xml broker files.
Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
This problem can be worked around by editing one of the broker files to increase the timeout setting. In order to do this, the PME iso must be unpacked. The file in question is in the 'setup' directory and is called 'broker.xml'. Note that the timeout setting is in milliseconds.
Find this section:
<BrokerRequest Name="GetSqlInstanceList">
<Request Name="GetSQLServerList" EstTime="500" TimeOut="100000" UIName="#determinesqledition" ActionOnFail="Stop">
<Method>
<GetServerListEnumDelim Library="DatabaseUtilities" Class="Installer.InstallTools.ConfigureSQL">
<includeInstance>true</includeInstance>
</GetServerListEnumDelim>
</Method>
</Request>
Change the TimeOut setting from 100000 to 600000. The edited section of the file should look like this:
<BrokerRequest Name="GetSqlInstanceList">
<Request Name="GetSQLServerList" EstTime="500" TimeOut="600000" UIName="#determinesqledition" ActionOnFail="Stop">
<Method>
<GetServerListEnumDelim Library="DatabaseUtilities" Class="Installer.InstallTools.ConfigureSQL">
<includeInstance>true</includeInstance>
</GetServerListEnumDelim>
</Method>
</Request>
After editing the file, save it, and then rerun the installer. Be sure to choose 'Restart' not 'Resume'
Additional Note
The timeout value will be increased for the next PME release.
When trying to install Power Monitoring Expert 8.x/9.0 on a standalone server on which SQL Server has already been installed, the PME installer is not able to find this existing SQL Server instance and the only option given is to install SQL Express. SQL Server is clearly installed, and the SQL Server and SQL Browser services are both running.
Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Environment
A new PME install on a standalone server. SQL Server has already been installed as per the System Guide.
Cause
The PME installer queries the system to find a list of existing SQL Server instances. It imposes a 100 second timeout. If it takes longer than 100 seconds to obtain this list of SQL Server instances, the installer will advance to the screen that tells the user no SQL Server instances were found and offers to install SQL Server Express. This timeout setting is contained in one of the xml broker files.
Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
This problem can be worked around by editing one of the broker files to increase the timeout setting. In order to do this, the PME iso must be unpacked. The file in question is in the 'setup' directory and is called 'broker.xml'. Note that the timeout setting is in milliseconds.
Find this section:
<BrokerRequest Name="GetSqlInstanceList">
<Request Name="GetSQLServerList" EstTime="500" TimeOut="100000" UIName="#determinesqledition" ActionOnFail="Stop">
<Method>
<GetServerListEnumDelim Library="DatabaseUtilities" Class="Installer.InstallTools.ConfigureSQL">
<includeInstance>true</includeInstance>
</GetServerListEnumDelim>
</Method>
</Request>
Change the TimeOut setting from 100000 to 600000. The edited section of the file should look like this:
<BrokerRequest Name="GetSqlInstanceList">
<Request Name="GetSQLServerList" EstTime="500" TimeOut="600000" UIName="#determinesqledition" ActionOnFail="Stop">
<Method>
<GetServerListEnumDelim Library="DatabaseUtilities" Class="Installer.InstallTools.ConfigureSQL">
<includeInstance>true</includeInstance>
</GetServerListEnumDelim>
</Method>
</Request>
After editing the file, save it, and then rerun the installer. Be sure to choose 'Restart' not 'Resume'
Additional Note
The timeout value will be increased for the next PME release.
發佈於: 施耐德電機Taiwan




需要協助?
產品選型工具
快速輕鬆地為您的應用找到合適的產品和附件。
取得報價
立即線上提交您的銷售需求,專業團隊將主動聯繫您。
購買地點
輕鬆在您所在地區找到最近的施耐德電機經銷商。
支援中心
在同一位置找到滿足您所有需求的支援資源。