我們的品牌

Impact-Company-Logo-English Black-01-177x54

歡迎造訪施耐德電機全球網站

歡迎訪問我們的網站
		
我们今天能为您提供什么帮助?
Hierarchy Manager Fails to Upload Records
Issue
When changing tabs in Hierarchy Manager, the system tries to upload records. However, after a few minutes, it fails and shows the following message:

Hierarchy message from webpage
Loading records...
Failed to load data from the server. Please try again.

Product Line
Power Monitoring Expert 9.0

Environment
Hierarchy Manager

Cause
By default, the hierarchy manager has to upload records within 2 minutes. If it doesn't manage to upload within this time, it will fail.

Resolution
Change the Javascript file for HierarchyManager to increase the timeout. The file is:

...\Power Monitoring Expert\applications\HierarchyManager\Scripts\HierarchyManager\data.nodemodel.js

Find the following code snippet:

$.ajax({
type: "GET",
url: baseUrl,
timeout: 2*60*1000, // 2 minutes. Some hierarchy pages can take a long time to generate.
data: { nodeQuery: JSON.stringify(nodeQuery) },
dataType: "json",
success: onSuccess,
error: onError,
page: page
});

Change the timeout to 4*60*1000. This increases the timeout to 4 minutes.

*Note: This solution does not apply to versions of PME after PME 9.0

施耐德電機Taiwan

探索更多
系列:
探索更多
系列:
  • 產品文檔
  • 軟體下載
  • 產品選型工具
  • 產品替代和替換
  • 幫助和聯絡中心
  • 尋找我們的辦公室
  • 取得報價
  • 施耐德電機社群
  • 人才招募
  • 公司簡介
  • 舉報不當行為
  • 無障礙
  • 新聞中心
  • 投資者
  • 專業洞察
  • 台灣施耐德電機學院
  • 綠色影響力落差調查
  • Schneider Go Green 2025
  • 隱私政策
  • Cookie通告
  • 使用條款
  • Change your cookie settings