我們的品牌

Impact-Company-Logo-English Black-01-177x54

歡迎造訪施耐德電機全球網站

歡迎訪問我們的網站
		
我们今天能为您提供什么帮助?
Why can I not start the "SQL Server (MSSQLSERVER)" service?

Issue
User is unable to start the "SQL Server (MSSQLSERVER)" service on PME server. When a user tries to start the service the following error pops up "Windows could not start the SQL server (MSSQLSERVER) on Local Computer... (error code 3417)". Below is a screen shot of the error message.

windows could not start the sql server

Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020

Environment
Windows Services

Cause
There are multiple known causes for this issue. The SQL server could have been shut down unexpectedly or the databases could have been moved to a different drive are two possibilities.

Resolution
The error code referenced in the error message indicates that there is a problem with the master database. The most likely problem is the master database is corrupted due to one of the causes listed above.

  1. To fix this problem, you will simply need to replace the current master.mdf and mastlog.ldf files with the default template files.
  2. To do this, navigate to the following path " C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL".
  3. There you will find a folder "Template Data", copy the master.mdf and mastlog.ldf
  4. Replace it in the following path "C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL\Data folder".

That's it, now you should be able to start the "SQL Server (MSSQLSERVER)" service again.


施耐德電機Taiwan

探索更多
系列:
探索更多
系列:

需要協助?

  • 產品選型工具

    快速輕鬆地為您的應用找到合適的產品和附件。

  • 取得報價

    立即線上提交您的銷售需求,專業團隊將主動聯繫您。

  • 購買地點

    輕鬆在您所在地區找到最近的施耐德電機經銷商。

  • 支援中心

    在同一位置找到滿足您所有需求的支援資源。

  • 產品文檔
  • 軟體下載
  • 產品選型工具
  • 產品替代和替換
  • 幫助和聯絡中心
  • 尋找我們的辦公室
  • 取得報價
  • 人才招募
  • 公司簡介
  • 舉報不當行為
  • 無障礙
  • 新聞中心
  • 投資者
  • 專業洞察
  • 台灣施耐德電機學院
  • 綠色影響力落差調查
  • Schneider Go Green 2025
  • 隱私政策
  • Cookie通告
  • 使用條款
  • Change your cookie settings