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Why can I not start the "SQL Server (MSSQLSERVER)" service?

Issue
User is unable to start the "SQL Server (MSSQLSERVER)" service on PME server. When a user tries to start the service the following error pops up "Windows could not start the SQL server (MSSQLSERVER) on Local Computer... (error code 3417)". Below is a screen shot of the error message.

windows could not start the sql server

Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020

Environment
Windows Services

Cause
There are multiple known causes for this issue. The SQL server could have been shut down unexpectedly or the databases could have been moved to a different drive are two possibilities.

Resolution
The error code referenced in the error message indicates that there is a problem with the master database. The most likely problem is the master database is corrupted due to one of the causes listed above.

  1. To fix this problem, you will simply need to replace the current master.mdf and mastlog.ldf files with the default template files.
  2. To do this, navigate to the following path " C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL".
  3. There you will find a folder "Template Data", copy the master.mdf and mastlog.ldf
  4. Replace it in the following path "C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL\Data folder".

That's it, now you should be able to start the "SQL Server (MSSQLSERVER)" service again.


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