Could not write to Event log pipeline in Alarm Service." after upgrading PME
Issue
Events from devices and Software Alarms don't show up in Alarms and are not written to the database.
Example of the error message in the System Log:
ID: 3367495
Timestamp: 13/02/2020 9:40:38,107
Priority: ERROR
Source: Software Data Processing Service
Target: EventLogWriter
Category: Computer General
Computer: COMPUTERNAME
Description: Could not write to Event log pipeline in Alarm Service.
ID: 3367494
Timestamp: 13/02/2020 9:40:38,087
Priority: ERROR
Source: Software Data Processing Service
Target: LogAcquisitionMessenger
Category: Computer General
Computer: COMPUTERNAME
Description: Message Write Failure: Error sending message on queue '.\private$\LogSubsystemPrimaryRouter_Data'.; ErrorCode: [AccessDenied]; Body: DataMessage: Operation [Insert]; Filtered [False] Retry [0]
Product Line
Power Monitoring Expert 7.2.2
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
PME Web Application
Alarms
Cause
The ION Log Subsystem Router Service is running under a user that does not have access to the message queues or the message queues were not built correctly.
Resolution
Confirm that the user permissions for the Log Subsystem Router Service is allowed access cloudagent_control, cloudagent_data, logsubsystemprimaryrouter_control, logsubsystemprimaryrouter_data, logsubsystemsecondaryrouter_control, logsubsystemsecondaryrouter_data Private Queues.
- Open Computer Management on the PME Server.
- Open Services and Applications > Message Queuing > Private Queues
- Right click on each of the 6 queues, select Properties, and open the Security tab.
- Confirm each of these queues permissions:
- "Everyone" group has access to allow:
- Get Properties
- Get Permissions
- Send Message
- "LOCAL SERVICE" or if applicable, the user set to run the "ION Log Subsystem Router Service", should have full access to the queue
- Full Access
- "ANONYMOUS LOGON" group should only have access to:
- Send Message
- "Everyone" group has access to allow:
If adding everyone does not solve the issue then recreate the queues:
- Stop all PME services
- Delete the 6 message queues
- Start the Network Router Service
- Start Log Inserter Service
- Start the Log Subsystem Router Service
- Start all other PME services
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