Cannot login to PME web with error, "User is not licensed"
Issue
The following error occurs when the user tries to login into PME Web:
Access denied. This user is not licensed for web access.
• The problem happened even when no other user was logged in PME Web.
• By default PME comes with 2 web licenses, included in Base License (applies to both PME 9.0 and above versions upto PME2023). In this case 2 additional web licenses were purchased, for a total of 4 licenses.
Product Line
Power Monitoring Expert (9.0, 2020, 2021, 2022 & 2023)
Notes:
- The problem was observed in PME 9.0 but it could apply to other versions as well
- The script (in resolution section) works in 9.0, 2020, 2021, 2022 & 2023
Environment
PME Web Application
Cause
Exceeding the number of PME Web licenses
Resolution
Database Warning: “This article contains information about editing the database. Please note, editing or updating anything in DB may cause permanent damage and result in PME to function improperly. This procedure should only be performed by users familiar with SQL Server Management Studio. Kindly take a backup of the database before performing any such action."
Licenses are assigned to users. In case there were previous users, the assigned license needs to be freed.
In order to achieve this run the following script:
delete FROM [ION_Network].[dbo].[GroupMembershipMap]
where TrusteeID NOT IN (SELECT UserID FROM [ION_Network].[dbo].[Users])
For convenience the script is attached to this article.
發佈於: 施耐德電機Taiwan


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