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Video: What can be done when PowerView display buttons do not work properly?
Issue
The PowerView display interface does not react as expected when the user presses one or more buttons or shows incorrect/incomplete text.

Product Line
PowerView display interface - AP9215, AP9215RM, WAP9215RM

Environment
Any product that uses the PowerView display interface

Cause
Common reasons for unusual PowerView behavior are loose/damaged communications (CAT5) cable, corrupted firmware, or stuck/damaged buttons.

Resolution
If the display is not reacting as expected, please try the following steps:
  1. Reboot the display by unplugging the cable that connects it to the UPS.
  2. If the issue persists, check for any buttons that are stuck in the "down" position.  A stuck button can often cause the display to act as if a different button is being pressed e.g. if the user presses the enter key, the display will act as if the down arrow is pressed.
  3. Re-flash the firmware of the display interface.  See knowledge base article FA156046.
  4. Replace the display interface.

The following video demonstrates common troubleshooting techniques and replacement procedure for the PowerView display:

Schneider Electric UK

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