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PME 2020 - Why the Personal Preferences setting is not editable.
Issue:
When you navigate to PME Web App > Settings > Personalization > Personal Preferences you see all the fields are inactive and can not be edited. There is also an error message indicating that there is an issue in getting User details. This happens only with PME Standard users. If you login to the Web App using a Windows account then everything works properly.


Product Line:
Power Monitoring Expert 2020

Environment:
PME Web Application

Cause:
This happens when there is some issue in Web.config file located in ...\Power Monitoring Expert\applications\SystemDataService folder. You may see a warning message in the Windows Application event log similar to the below one.


Below is the full message;

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 13.02.2020 08:56:26
Event time (UTC): 13.02.2020 07:56:26
Event ID: 06cebb5e6d0f4ff787b6be9470e420a7
Event sequence: 141
Event occurrence: 2
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/SystemDataService-2-132260538304121462
Trust level: Full
Application Virtual Path: /SystemDataService
Application Path: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\SystemDataService\
Machine name: OV-DA13A1

Process information:
Process ID: 13560
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: HttpException
Exception message: Une valeur Request.Path potentiellement dangereuse a été détectée à partir du client (:). [English translation: A potentially dangerous Request.Path value was detected from the client (:).]
at System.Web.HttpRequest.ValidateInputIfRequiredByConfig()
at System.Web.HttpApplication.PipelineStepManager.ValidateHelper(HttpContext context)



Request information:
Request URL: https://ov-da13a1:443/SystemDataService/StandardUsers/data/StandardUsers/internal:database:1e958082-9de0-436f-ab64-d942ca0b645d:supervisor
Request path: /SystemDataService/StandardUsers/data/StandardUsers/internal:database:1e958082-9de0-436f-ab64-d942ca0b645d:supervisor
User host address: fe80::f816:3eff:fe25:ee03Full
User:
Is authenticated: False
Authentication Type:
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 42
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace:    at System.Web.HttpRequest.ValidateInputIfRequiredByConfig()
at System.Web.HttpApplication.PipelineStepManager.ValidateHelper(HttpContext context)



Resolution:
  1. Stop all 3 ION Application Module services.
  2. Take a backup of Web.config file from ...\Power Monitoring Expert\applications\SystemDataService folder.
  3. Replace the file with the attached one.
  4. Start the services.
  5. perform IIS reset.

Schneider Electric UK

Attachment(s)
web_config.zip [1.9 KB]
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