Our Brands

Impact-Company-Logo-English Black-01-177x54

Schneider Electric USA Website

Welcome to our website.
		
How can we help you today?
How can I change the EWS service in Power Monitoring Expert to use a port other than port 80 (the default)?

Issue:
Customer would like EWS service to run under a different port other than the default port 80.

Product Line:

Power Monitoring Expert 7.2

Power Monitoring Expert 8.x

Power Monitoring Expert 9.x

Power Monitoring Expert 2021

Power Monitoring Expert 2022

Power Monitoring Expert 2023

Power Monitoring Expert 2024


Environment:
EWS Server Configuration

Cause:
Customers can have specific needs to have EWS running under a custom port instead of the default port 80.

Resolution:

Changing the Port number for the EWS service:

  1. Open IIS by entering the “inetmgr” in the RUN command and enter.

Run command

  1. Remove the existing Web application from the IIS.

iis

  1. Create new Website for the EWS service:

creating website

  1. Enter the Site name as EWS and select the EWS path($\Schneider Electric\ION Enterprise\Applications\EWS) in the Physical path section  and enter the unused port number,  as per the following screenshot:

add website

  1. Select the Advanced settings of the EWS Website.

advanced setting

  1. Select the Application pool as “Application Modules AppPool” as per the following screenshot.

setting

  1. Browse the DataExchange.svc. browse

  1. On browsing the EWS service, the user will be prompted to enter username & password. Enter the PME username & password.

dataexchange

  1. Copy the EWS service URL from the browser (Address bar) and update the Web.config file from the following location ($\Schneider Electric\ION Enterprise\Applications\EWS).

Replace the existing URL as given in the following screenshot with the copied URL from the browser.

copy service

Now the EWS service works with the new port number configured in the new EWS website.



Schneider Electric USA

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:
  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact Center
  • Where to buy
  • Get a Quote
  • Find our Offices
  • Schneider Electric Community
  • Careers
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Newsroom
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Tech Support: 877-342-5173
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings