Issue:
A user sees the error messages "Metadata query failed for: breeze/EnmConfig/Metadata; A network-related or instance-specific error occured while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)" when clicking on the link to ENM Configuration (localhost:82 or <server IP>:82.) Also shown in Figure 1 below.
Figure 1: Error Message
Product Line:
Power Monitoring Expert 7.2
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
ENM- Event Notification Module: 8.x
- Note: Starting with PME 2021, ENM is integrated into the PME Web Applications.
Cause:
This is caused by the web.config xml file not pointing to the correct name/instance of the SQL server. The web.config file has a connection string to the SQL server and that connection string is incorrect.
Resolution:
Navigate to the <Install Drive>\Program Files (x86)\Schneider Electric\StruxureWare Solutions\Websites\EnmConfig folder and change the connection string in Web.config.xml to include the correct server name/instance. The image below shows the connection string section of the Web.config.xml file.
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop)
Recommendation:
If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com