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ION_Network and ION_Data backups scheduled in Task Scheduler read task completed successfull but no backups were generated.

Issue
When Scheduling database backups for ION_ Network and ION_Data in Task Scheduler, the event shows that the task was completed successfully but no backups  were generated.
task scheduler

Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x

Power Monitoring Expert 2020

Power Monitoring Expert 2021

Power Monitoring Expert 2022

Power Monitoring Expert 2023

Power Monitoring Expert 2024

Environment
Database maintenance tasks using Windows Task Scheduler

Cause
No backups are being generated from Task Scheduler

Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

Open SQL Management Studio, login with windows authentication and expand Databases, expand ION_Network, then expand Security andUsers, right click on servername\IONMaintenance and select properties. Under User name make sure the IONMaintenance user is associated with the login name.

The screen shot below shows no IONMaintence under the login name and is grayed out, this is the reason no backups are generated for ION_Data and ION_Network.
SSMS permission

To resolve this problem, please follow the steps below:
1. Delete the IONMaintenace User and recreate it by right clicking on Users and selecting New User enter severname\IONMaintenance
2. Make sure the IONMaintenance user shows under User name and Login name.
3. Under Database role membership, make sure db_backupoperator, db_ddladmin and Maintenance are checked.

The screen shot below shows correct configuration for IONMaintenace user
SSMS permission

4. Repeat the same steps for ION_Data.

Recommendation:

If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com

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