While running a database archive, the archive or trim will fail with a 'timeout expired' error as shown below:
Running the archive or trim again over a much shorter time interval, such as an hour, will succeed.
Product Line:
Power Monitoring Expert 7.2.2
Environment:
Database Manager
Database Trim and Archive
Cause:
There were a number of timeout settings with Database Manager that were causing these issues. The timeouts were mainly a 30 second Trim timeout and an 18 hour archive timeout.
Resolution:
There is a hotfix available that will remove these timeout settings. In addition, the attached hotfix will also speed up the trim and archive process, without the unwanted side effects of a huge transaction log size increase and database tables locking up.
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
To deploy the hotfix:
1. Rename databasearchive.dll and databasetrim.dll located in the ...\Power Monitoring Expert\system\bin folder to a different name
2. Copy in the new versions of these files to ...\Power Monitoring Expert\system\bin folder
3. In SQL Server Management Studio - run the scripts in the following order: PME7_ArchiveDBCopyDataLog.sql, then PME7_ArchiveDB_new.sql, then PME7_TrimRecords.sql.
Released for: Schneider Electric Vietnam
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