Issue
When running a PME web report and outputting to an XML File, the customer sees a 'Could not render report. Please contact your system administrator' error message. Looking in the SystemLog, the following error appears - "Unexpected error from external database driver"
Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Web Application
Cause
A Windows security update rolled out in October 2017 which updated the Jet.OLEDB 4.0 provider. It is an old MS component we use to convert an Excel spreadsheet into xml. Installing this update may cause applications based on the Microsoft JET Database Engine (Microsoft Access 2007 and older or non-Microsoft applications) to fail when creating or opening Microsoft Excel .xls files. The error message is, “Unexpected error from external database driver (1). (Microsoft JET Database Engine)." In the case of web applications, it was XML files that failed.
Resolution
Microsoft has released a November security rollup that resolves this issue. If you see this issue, apply the update from the link below:
Microsoft November rollup.
Released for: Schneider Electric Vietnam

