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Product Line
Configuration Manager Tool 2.1.0 (CM Tool 2.1.0)
Environment
SBS Upgrade from ION6.0.1 to PME8.2 if the regional settings of the OS are not set to English
Issue
When "Writing to System" using the CM Tool v2.1.0, the tool will not be able to upgrade the databases - ION_Network, ION_Data and any of the archives.
The log file will show erros similar to:
" |Error||High||Upgrade Network Database||Failed to parse '12.1' into double||Business "
"||Error||High||Upgrade Historical Database||Failed to parse '4.2' into double||Business "
Cause
The workaround to allow the tool to upgrade the databases successfully is to change the region in the target OS system to English (just to complete the upgrade. Customer can revert the settings after the tool writes to the system.
To change the settings:
1) Open Control Panel > Region
2) In the Formats tab, change the Format to "English (United States)"
3) In the Location tab, change the Home Location to "United States"
4) You must restart the server
After you successfully write to the system, you may restore the regional settings back to the normal configuration.
Configuration Manager Tool 2.1.0 (CM Tool 2.1.0)
Environment
SBS Upgrade from ION6.0.1 to PME8.2 if the regional settings of the OS are not set to English
Issue
When "Writing to System" using the CM Tool v2.1.0, the tool will not be able to upgrade the databases - ION_Network, ION_Data and any of the archives.
The log file will show erros similar to:
" |Error||High||Upgrade Network Database||Failed to parse '12.1' into double||Business "
"||Error||High||Upgrade Historical Database||Failed to parse '4.2' into double||Business "
Cause
The cause of the issue is this line of code: double.TryParse(value, out dbl))
It fails to parse the 14.1 or 4.2 into a double number. The values 14.1 and 4.2 are in the WriteToSystem.Jobs.xml file
This will happen for some regional settings which uses comma as a decimal separator.
ResolutionIt fails to parse the 14.1 or 4.2 into a double number. The values 14.1 and 4.2 are in the WriteToSystem.Jobs.xml file
This will happen for some regional settings which uses comma as a decimal separator.
The workaround to allow the tool to upgrade the databases successfully is to change the region in the target OS system to English (just to complete the upgrade. Customer can revert the settings after the tool writes to the system.
To change the settings:
1) Open Control Panel > Region
2) In the Formats tab, change the Format to "English (United States)"
3) In the Location tab, change the Home Location to "United States"
4) You must restart the server
After you successfully write to the system, you may restore the regional settings back to the normal configuration.