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Power Monitoring Expert (PME) Reports Subscriptions write to fileshare fails "Please check the fileshare path..." System log reads "Could not authenticate."

Issue
In the PME web application reports, a subscription test to write to a file share fails due to an error: "The report name could not write subscription to file share. Please check the file share path and try again. Note that the Windows user account IONUser must have permission to write to the file share."
PME Report Subscriptions Write to Fileshare Error Message. "Could not write subscription to fileshare. Please check the fileshare path and try again or contact your system administrator. Note that the Windows user account IONUser must have permission to write to the fileshare."

In the web application --> settings --> system log, the following error message indicates a "Could not authenticate" error:
"LogClientExtendedInformation: System.ApplicationException: Could not authenticate.
at PowerMeasurement.Security.UserImpersonator..ctor(String userName, String password, String domain)
at WebReporter.Reporter.Subscriptions.SubscriptionDetailsControl.InitPrinterControl()"

Note: Ensure the file path name is correct and IONUser has the permissions described in the PME official system

Image from PME Official System Guide. "IONUser (account) has no group membership, has list/read/write/execute permissions on the PME share folder." Notes: Automatically created. Used to run reports subscriptions. Needs access to the folder where subscriptions are saved."

Product line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment
PME Web Applications
PME Reports
Windows Event Viewer

Cause
The IONUser Windows account requires authentication. In the Windows event viewer, an event can be seen that indicates IONUser logon failed.

Screenshot of Windows Event Viewer warning "Unknown user name or bad password."

Resolution

  1. Open the PME installer as an administrator. (In Windows, search for "Apps & Features", locate PME, and right-click to select "modify").
  2. Select the button "reset accounts."
  3. Click "Next" on the installer until you see the "Windows accounts" page.
  4. Select "change password" to change the IONUser password, keep in mind this will also change the IONMaintenance password.

NOTE from the PME official system guide: "If you change the password, the password you are providing must comply with the password policies of the Windows server and the SQL server. The software installer cannot validate the password at the time you enter it."

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