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Why can’t I add Share, Print or E-mail subscriptions in WebReporter?

Issue


The following error occurs when trying to share, print or create an email report subscription in PME Web Application-->Reports

"An unexpected error has occurred. Your request cannot be processed at this time. If the problem persists, contact the Webpage administrator".

An error will appear in the System Event log in the Management Console:

10/21/2012 5:55:52 PMWeb ReportertextION Web GeneralComputer1Could not authenticateERROR

If the EventException table in ION_SystemLog is examined, the following stack traces will be seen:

System.ApplicationException: Could not authenticate. at PowerMeasurement.Security.UserImpersonator..ctor(String username, String password, String domain) at PowerMeasurement.Apps.Web.EEM.Modules.Reports.AddRSReportSubscription.InitPrinterControl() at PowerMeasurement.Apps.Web.EEM.Modules.Reports.AddRSReportSubscription.Page_Load(Object sender, EventArgs e) at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



Product Line

Power Monitoring Expert 9.0

Power Monitoring Expert 2020

Power Monitoring Expert 2021

Power Monitoring Expert 2022

Power Monitoring Expert 2023

Power Monitoring Expert 2024

Environment

Web Applications Report



Cause


The reason for this behavior is that two of the three subscriptions, and the "Add" button, perform operations that require User Impersonation.
The code attempts to "log in" to Windows as IONUser to poll for a list of configured printers ("Add" button), write to a file share (subscription), or send to a printer (subscription).

Manage reports

The aforementioned error can be caused by several things.
Cause 1. This error can also be caused when the Windows IONUser password has been changed.

Cause 2. Web Reporter subscriptions will not work unless the Security Policy settings for "Allow log on locally" is granted to the IONUser (a member of the Users group) on the server.


Resolution

Resolution 1: Change the Windows IONUser password back to the default, IONisgreat!, or update SQL Server Management Studio to reflect the new password. For instructions on updating SQL Server Management Studio, see FA208369.

Resolution 2: Make IONUser a member of a group that can log on locally or give IONUser permission to log on locally.

Method 1: Give IONUser permission to log on locally
  1. Navigate to Control Panel → Administrative Tools → Local Security Policy
  2. Inside of Local Security Policy navigate to Local Policies → User Rights and Assignment
Security Policy

  1. Select Allow log on locally. Here you will see the groups that are allowed to log on locally.
Properties
  1. Select Add User or Group.
  2. Enter IONUser and select Check Names. It will automatically enter the name of your PC in front of IONUser. Make sure the PC name is there then select OK
Select users
  1. Select OK to exit the Allow log on locally Properties window.
Method 2: Add IONUser to a group that can log on locally
  1. Navigate to Control Panel → Administrative Tools → Computer Management
  2. In computer, management navigate to Local Users and Groups → Users  and select the IONUser

Comp Management
  1. In the IONUser Properties navigate to Member Of and select Add
User properties
  1. Enter a group from the list that was shown in step three of the previous instructions and select Check Names.It will automatically enter the name of your PC in front of the selected group. Make sure the PC name is there then select OK

Group selection
  1. Select OK to exit the IONUser Properties window.

Recommendation:

If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com

Support details

Schneider Electric Canada

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