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User is seeing many system log errors from a XL20 after they upgraded from ION Enterprise to PME

Issues

System log errors coming from xl20 after upgraded from ION Enterprise to PME

Product Line
Power Monitoring Expert 7.x

Power Monitoring Expert 8.x


Environment
Device Communications

Cause
When ION Enterprise systems that include 3720 ACM devices are upgraded to Power Monitoring Expert 7.2.2, it is possible that the system log will be flooded with errors like:

An unknown exception occurred in XL20
Transaction error. Device: 'LVPML2.D148_Tie_To_J103'. Client: 'IONSERVICES.WALONAION12'. Reason: 'VSIN_MessageUndefined'
Transaction error. Device: 'LVPML2.B16_PACLAM'. Client: 'IONSERVICES.WALONAION12'. Reason: 'VSIN_PasswordLenErr'
Transaction error. Device: 'LVPML2.B16_PACLAM'. Client: 'IONSERVICES.WALONAION12'. Reason: 'VSIN_UnderflowStream'

These errors are typically only nuisance errors, but there can be many of them. There have been some cases where the Site Server service crashes as a result of these errors.

Resolution

1-Upgrade from ION Enterprise to PME 7.2 or PME 8.0
2-After PME 7.2/8.0 are installed, this can be corrected by applying the attached xl20.dll patch.

NOTE: The patches changes from version to version. Be sure to match the patch to the software version.


*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
To deploy:
1. Shut down the ION Site Server service
2. Rename the existing file \system\bin\xl20.dll
3. Copy in the attached file
4. Restart the ION Site Server service


Schneider Electric Canada

Attachment(s)
PME8_Hotfix_46202-xl20.zip [363.59 KB]
PME722_Hotfix_46202_xl20.7z [255.74 KB]
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