Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
Why doesn't my TSXCUSBMBP work after I upgraded to Windows 10 and re-installed the MBX drivers?
Issue:
TSXCUSBMBP doesn't work after I upgraded to Windows 10 and re-installed the MBX drivers
Product Line:
Momentum PLC, Quantum PAC
Environment:
Control Expert v14
Unity Pro XL V13
Cause:
The drivers you have may be out of date or do not work with the 64 bit environment.
Resolution:
You will need to purchase version 9.0 of the MBX drivers through your local distributor.
If you have purchased the TSXCUSBMBP within the last 12 months, you may be able to get the MBX Driver suite for free.

Schneider Electric Canada

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:
  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact Center
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Schneider Electric Community
  • Careers
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Newsroom
  • Investors
  • EcoStruxure
  • Job Search
  • Register Your Product
  • Blog
  • Legal Information
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings