Can a customer call DPSG directly, for Drive and Softstart troubleshooting help?
Issue :
Drives Product Support Group direct contact number.
Product Line :
Altivar Drives & Altistart Soft Starts
Cause :
How to contact the support group for drive and soft start.
Resolution :
Yes. Call our Toll Free number at 1-888-778-2733.
Select option 1 to enter an existing case number, or key in your 5-digit Premier Support Contract number.
OR
Select option 2 for Technical Support Queue
And
Select option 4 for AC Drives and Softstarts
Email address is drive.products.support@se.com
Chat live via chat portal : Live Chat Support
Normal hours are 8am to 8pm EST, Monday to Friday. Emergency support is available outside normal hours for a fee or available to customers with a Premier Support Contract.
If this article does not answer your question, check out our FAQ database that has answers to more commonly asked questions:
If this FAQ did not solve your issue, you can call us at 1-888-778-2733 Option 2 and then 4 or e-mail us at drive.products.support@se.com to create a case with our Technical Support Team.
If you are not located in North America, please contact your local Customer Care Center for assistance:
Released for: Schneider Electric Canada
Need help?
Product Selector
Quickly and easily find the right products and accessories for your applications.
Get a Quote
Start your sales inquiry online and en expert will connect with you.
Where to buy?
Easily find the nearest Schneider Electric distributor in your location.
Help Center
Find support resources for all your needs, in one place.