How can we help you today?

NetBotz 5.4 upgrade error "Firmware update failed because of invalid signature (40)"

Issue:
NetBotz 5.4 upgrade error "Firmware update failed because of invalid signature (40)"

Product Line:
NetBotz

Environment:
NBRK0750
NBWL0755
NetBotz 5.4 firmware

Cause:
Prior versions of NetBotz 750/755 firmware allowed you to upgrade from any version to the most current. This is changed for 5.4. You will receive an error of "Firmware update failed because of invalid signature (40)" if attempting to upgrade from 5.3.4 or prior.

Resolution:
The NetBotz 5.4 update requires that the NetBotz appliance be at version 5.3.5 to work. If you're seeing the above error, make sure you update to 5.3.5 prior to upgrading to 5.4

Please check release notes for upgrade information as well as any future version requirements.

Schneider Electric Canada

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:
  • Help and Contact Center
  • Contact Sales
  • Find our Offices
  • Where to Buy
  • Careers
  • Company Profile
  • Investors
  • Newsroom
  • Report a Misconduct
  • Product Documentation
  • Product Selectors
  • Software and Firmware
  • Product Substitution and Replacement
  • Blog
  • Events
  • Schneider Electric Community
  • Sustainability
  • Legal Information
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings