How to resolve the error "The 'SQLNCLI11’ provider is not registered on the local machine."
Issue:
How to resolve the error "The 'SQLNCLI11’ provider is not registered on the local machine." This error is seen when trying to open the Tools menu or System Log Events, in Management Console.
Product Line:
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment:
PME Management Console
Cause 1
A connection error between SQL and PME has occurred.
Cause 2
The SQL Native Client version referenced in the error is not installed.
Resolution 1
1. Reboot the PME application server
2. If the issue persists, refer to this video https://youtu.be/XJmUCK5uqPY to test the SQL connection using a UDL file
3. Troubleshoot the connection to SQL server using suggestions from this Microsoft article: https://learn.microsoft.com/en-us/troubleshoot/sql/database-engine/connect/resolve-connectivity-errors-overview#common-connectivity-issues
Resolution 2
1. In the Windows Start menu, search for and open “ODBC Data Sources (32-bit)”
2. On the Drivers tab, scroll down and look for SQL Server Native Client 11.0
3. If not found in the list, download it from https://www.microsoft.com/en-us/download/details.aspx?id=50402
4. Install SQL Server Native Client 11.0 by running the ENU\x64\sqlncli.msi file
Released for: Schneider Electric Canada
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