How can we help you today?

How do I perform the initial internal battery connection? | Back UPS PRO BX

Issue:

The Back UPS PRO BX model (BX850M/1000M/1350M/1500M) does not power on or begin charging when first connected.

Product Line:

Back UPS PRO BX

Environment

  • BX850M-LM60

  • BX1000M-LM60

  • BX1350M-LM60

  • BX1500M-LM60

Cause:

When purchasing a UPS from the Back UPS PRO BX family, it is necessary to perform the initial connection of the internal battery before operating the unit. If this step is skipped, the UPS will not function properly or begin charging its batteries.

Resolution:

To connect, disconnect, or replace the internal battery, follow the steps shown in the images below:

8 image

7 image

Schneider Electric Canada

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:
  • Help and Contact Center
  • Contact Sales
  • Find our Offices
  • Where to Buy
  • Careers
  • Company Profile
  • Investors
  • Newsroom
  • Report a Misconduct
  • Product Documentation
  • Product Selectors
  • Software and Firmware
  • Product Substitution and Replacement
  • Blog
  • Events
  • Schneider Electric Community
  • Sustainability
  • Legal Information
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings