Issue
Sometimes, the login dialog for the EcoStruxure Site Server may appear partially cut off, preventing users from accessing the device.
Product Line
EcoStruxure Site Server
Environment
Windows login page
Cause
Window screen resolution and/or settings incompatible.
Resolution
This behavior is typically related to display scaling or resolution settings on the Windows machine, or remote display configurations when using Remote Desktop. Some legacy PME applications do not fully support modern monitor resolutions or OS scaling settings.
So, adjusting the display scaling to 100% (1:1) to ensure the login dialog renders correctly.
For example, the screenshot below shows the login dialog when Windows display scaling is set to 150%, which matches the issue described above.
To fix this:
- Navigate to Settings > System > Display.
- Change the scaling to 100% and select a resolution that fits your monitor.
Released for: Schneider Electric Canada

