Issue 1
During a Power Monitoring Expert install, the install utility fails on the following steps:
Create Virtual Directories with error: Request ConfigureVirtualDirectory fail at function call: CreateAppPool
Configure Virtual Directories with error: Request ConfigureVirtualDirectory fail at function call: CreateAppPool
Create Application Pool with error: Request ConfigureVirtualDirectory fail at function call: CreateAppPool
Configure Application Pool with error: Request ConfigureVirtualDirectory fail at function call: CreateAppPool
Issue 2
The Default Web Site is not installed.
Issue 3
Problem adding Virtual Directory: Web - Problem details: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)
When trying to start the Default Web Site in IIS the following error appears:
Product
Power Monitoring Expert
Environment
Software Installation
Internet Information Services (IIS)
Cause 1
The following services are disabled and must be enabled and set to Automatic to install SPM or PME software:
- ASP.net State Service
- IIS Admin Service
- Windows Process Activation Service
- World Wide Web Publishing
Resolution 1
1. Open services by going to Start -> Services.msc
2. Go to properties on each of the following services, set to 'Automatic' and start the service.
3. Re-try the SPM or PME Installer
Note: In some cases, group policies could be disabling these services. Please check with the IT department to add exceptions for the SPM or PME server.
Cause 2
IIS can be installed without the Default Web Site.
Resolution 2
Confirm Default Website is installed in Internet Information Services (IIS) Manager.
- Start -> Control Panel -> Administrative Tools and double click on Internet Information Services (IIS) Manager as shown below.
- Open the tree for the server name -> Sites -> Default Web Site
Cause 3
Ports 80 and/or 443 are in use by another software or process.
Resolution 3
Confirm which port is in use.
- Open Command Prompt as administrator.
- Type the command, netstat -aon | find ":<port number>"
netstat -aon | find ":80"
netstat -aon | find ":443"
- If the port is in use then a couple of lines will appear with a listening column on the right followed by the Process ID (PID) that is listening to that port. If the port is not in use then nothing will appear. In the example below, Process ID 5484 is using port 80
To fix the port conflict either the other software using the port (in the example above PID 5484) or the port related to PME needs to be modified.
To change the binding for the PME web follow the steps below.
- Open IIS (Start -> Control Panel -> Administrative Tools and double click on Internet Information Services (IIS) Manager as shown below).
- Open the tree for the server name -> Sites -> Default Web Site
- With Default Web Site selected, click "Bindings..." from the Actions column on the right side.
- Choose the binding that needs to be changed and select "Edit...".
- Change the port to an open port and click OK.