{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
How can we help you today?
Web Applications Log In fails with an error message in SPM/PME
Issue
When logging into the Web Applications the user providesa known correct User Name and Password however the login is unsuccessful.

SPM 7.0.x Login Screen with error message "Log on unsuccessful":
Login Error PME 7.x


PME 7.2.x Login Screen with error message "The user name or password you entered is invalid. Please check and try again.":
Login Error 2 PME 7.x
PME 8.x Login Screen with error message "The user name or password you entered is invalid. Please check and try again.":
Login Error PME 8.x


Product Line
StruxureWare Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x

Environment
Web Applications Login
Cause
There are several possible causes for the Web Applications failed login attempts. Below are some possible causes and solutions to the login failure.

Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

Resolution 1:
Make sure that the browser version is supported in the PME version that is installed. Check the supported browser version in FA211703

Resolution 2:
For the ionedsd user, add the NOM_DSD_Reader role for ION_Network and the ION_DSD_Reader role for ION_Data by opening SQL server Management studio and going to properties on the ionedsd account.

ionedsd  user mapping


Resolution 3:
Navigate to: http://localhost/Webservices/WebRealTime.svc and verify that there are no errors loading the page. If the error contains a message that the service is unable to start due to lack of memory, open the Task Manager and identify the processes that are using high amounts of memory. Identify if there are programs that can be stopped to free up memory. Verify that SQL's memory is limited by following FA213995 .

Resolution 4:
Within the ApplicationModules database Views, make sure that the "Configuration.ConfigurationSettings" keys point to the correct locations as shown below in red. The server should be set to the database server for the distributed system and the local machine for standalone configurations:

Key - IonDataConnectionString
Value - server=localserver\ION;database=ION_Data;uid=ionedsd;pwd=exw1BStLAmzokMLd4uiXLouELuCl037YUD;MultipleActiveResultSets=True

Key - IonNetworkConnectionString
Value - server=localserver\ION;database=ION_Network;uid=ionedsd;pwd=exw1BStLAmzokMLd4uiXLouELuCl037YUD;MultipleActiveResultSets=True

Resolution 5:
Grant permissions to Connect SQL. To do this, navigate to Microsoft SQL Management Studio. Then go to the security folder. When the security folder is expanded, right-click on ionedsd and select the ionedsd properties. When the Login Properties - ionedsd pop-up window is available select the Securables page. From here scroll down under the Explicit tab until you find Connect to SQL. Check the box under Grant. Select OK.

ionedsd securables

Resolution 6:
The value in the [Signature] field within the [DataSourceBus].[DataSource] table found in the ApplicationModules database needs to be copied to the following file:
C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\bin​\DataServicesHost.config

DataSourceBus.DataSource Table

*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).

The setting within the DataServicesHost.config file as shown below from a test PME system must match the value found in the database.  If it doesn't, you can manually edit DataServicesHost.config to match the signature field value in the database.

<?xml version="1.0"?>
<configuration>
<appSettings>
<add key="ServiceHostId" value=""/>
<add key="Role" value="DataBus,IonEnterpriseDataSourceDriver,Hierarchy"/>
<add key="DataSourceDriverInstance" value="ION Enterprise-Default" />
<add key="DataSourceSignature" value="2e7666ed-c948-46ad-9994-6cd9623c276f"/>
</appSettings>
</configuration>

Resolution 7:
If the system requires a fully qualified domain name (ie http://pme.schneider-electric.com/web) to access the webpage, then the following database entries may need to be updated to allow for javascript to be loaded to the webpage and encode the user's password: ApplicationModules > Views > Configuration.ConfigurationSettings and ION_Network > Views > dbo.vCFG_ConfigItems.

To update the aforementioned database entries, perform the following:
  1. Login into SQL Server Management Studio
  2. Navigate to ApplicationModules > Views
  3. Right-click on Configuration.ConfigurationSettings and select Edit Top 200 Rows
  4. Locate the entry where
    • ItemType = WebFramework
    • Item = Server
    • Key = LocalServerAddress
  5. Update this entry to reflect the fully qualified domain name.
    • For example, update the entry to be something like http://pme.schneider-electric.com/web.
  6. Navigate to ION_Network > Views
  7. Right-click on dbo.vCFG_ConfigItems and select Edit Top 200 Rows
  8. Locate the entry where
    • Module = Reporting
    • Category = General Settings
    • Item = WebServiceURL
  9. Update this entry to reflect the fully qualified domain name.
    • For example, update the entry to something like http://pme.schneider-electric.com/ionreportdataservice/ReportDataService.asmx.
  10. Perform an IISReset and restart the ApplicationModules services
Resolution 8:
If none of the above Resolutions resolves the problem, please follow these steps:
  1. Remove IIS (Internet Information Service Manager). In order to do that, type in Server Manager in Windows Start. Open 'Manage' and select 'Remove Roles and Features' from the Menu bar. After it is removed completely, add it again.
  2. Run 'PME Reconfigure'. In order to run PME Reconfigure, go to Control Panel, select Programs, then Programs and Features, select PME software from the list, and click on 'Change'. When Power Monitoring Expert Installer shows up select Reconfigure.

Schneider Electric New Zealand

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: