{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.

Search FAQs

What causes E-17 fault on an ATV21 / ATV212 series drive?

Issue:
E-17 fault on ATV21 / ATV212 drives

Product Line:
ATV21 and ATV212 series drives

Environment:
All models, All serial numbers

Cause:
Clarification of fault code needed

Resolution:
E-17 is displayed on the ATV21 / ATV212 series drives when a button on the keypad is held down for more than 20 seconds.
If no button is being held down, then this could be a stuck key. Attempt to free a stuck button by powering down the drive and repeatedly pressing/releasing all keypad buttons.

This could also be an electrical problem with the switch where it is making contact when it is not being pressed, or possibly a problem with the microprocessor that thinks the button is being pressed when it is not.

As there are very few replacement parts for the ATV212 series, and none for the ATV21 series, replacement of the entire drive is often necessary to correct this problem.

Schneider Electric New Zealand

Explore more
Range:
Explore more
Range:
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.