Issue
Troubleshooting tips when establishing communications to meters
Product Line
CM3000 (CM3), CM4000 (CM4),
PM2000, PM3000, PM5000/PM5350, PM8000
Enercept, MCM, BCPM, BCM, Energy Meters, EM3500, EM4800,
ION6200, ION7300/7330/7350, ION7400, ION7550/7650, ION8600/ION8650, ION8800, ION9000/ION9000T
Environment
ION Setup
Power Monitoring Expert 8.2
PME2020, PME2021, PME2022, PME2023, PME2024
EPO2020, EPO2021, PO2022, PO2024
Cause
Basic communications (comms) troubleshooting steps for meters and gateways
Resolution
CM3000 (CM3), CM4000 (CM4),
PM2000, PM3000, PM5000/PM5350, PM8000
Enercept, MCM, BCPM, BCM, Energy Meters, EM3500, EM4800,
ION6200, ION7300/7330/7350, ION7400, ION7550/7650, ION8600/ION8650, ION8800, ION9000/ION9000T
Environment
ION Setup
Power Monitoring Expert 8.2
PME2020, PME2021, PME2022, PME2023, PME2024
EPO2020, EPO2021, PO2022, PO2024
Cause
Basic communications (comms) troubleshooting steps for meters and gateways
Resolution
ETHERNET:
- Check link lights on the back of meter
- Check LAN cable and follow connection. Use straight cable to a switch, cross over for a direct meter-to-computer connection
- Can you Ping the meter? What are the results?
- From meter, through hubs/switches to the computer
- IP Address conflicts? (Meter does not support DHCP)
- Too many users? Try: telnet <meter IP>
- Turn off firewalls that may be blocking ports 7700, 7701, 7801, 7802, 502, 3721, 3722
- Telnet into meter and check the ETH statistics to see network related probs.
- Check diagnostics viewer from Management Console to see total errors and what type of errors.
- Check diagnostics viewer from Management Console to see when the meter had a last response, and then check switch logs
- Status “Failure” in Management Console? Then restart services
- ION6200: Does the options card have the appropriate options to allow communication?
INTERMITTENT:
- Check how many concurrent connections you have. If all 4 are filled up sometimes, you will get intermittent connections.
- EMI (noise) is large. Use a higher-grade shielded wire.
- Increase the timeout delay on both the meter and the software if the communication path is long and lossy
- DCOM errors are preventing communication (see incident 228482) (see KB11361) (Questionable if valid)
MODBUS:
- Ensure Modbus map is correct
- Ensure Modbus import module variable type = Modbus slave module variable type (eg signed 32bit)
- You must have only one master and may have multiple slaves
- If writing Modbus command to the meter is not possible, disable standard security from the front panel
- Check RS485 heading below (Get them to set all protocols to ION/Ethergate to isolate prob. away from wiring)
RS232 (Direct computer to meter):
RS232 (Direct meter to meter):
RS485 (Computer > RS232/RS485 converter > meters):
PHYSICAL | SOFTWARE |
|
|
RS232 (Direct meter to meter):
METER 1 | METER 2 |
|
|
RS485 (Computer > RS232/RS485 converter > meters):
PHYSICAL | SOFTWARE |
|
|
MODEM (Direct computer > modem1 > PSTN > modem2 > meter (RS232)
- Comp-to-modem cable should be a straight-thru RS232 cable. Same with modem-to-meter
- Any other program possibly using the com port should be stopped
- Do the modems make proper connect noises?
- YES: - Send a transmit: START > RUN > cmd > TYPE: echo xyz > comX (where X=com port at computer)
You should see the Tx light on the Computer modem and the Rx on the meter modem flash. If not, make sure the modems internal registers have the same settings (flow control, parity, start/stop bits, etc). This can be set by sending AT strings
- YES: - Send a transmit: START > RUN > cmd > TYPE: echo xyz > comX (where X=com port at computer)
- Ensure DIP SW on COM128 are set according to the above settings in the meter modem
PME:
- Can you connect with ION Setup?
- Check Site Overview: in Management Console
- Tools > System > Diagnostics Viewer > expand tree > Site Overview
Now check to see how many good and bad responses. Then go to the meter listed below and in the right window, look for bad checksum, bad frame, etc.
- Tools > System > Diagnostics Viewer > expand tree > Site Overview
- If you are connecting via Ethergate, ensure you have created a site
- If you are connecting via modem:
- Create a modem in the modems icon in Management Console (Ensure it is enabled and that the com port is not already being used by a site in management console)
- Create a site and under modems, select the modem you created in a. (Ensure it is enabled.
- Create a device. In the device properties, set site to the site you created in b. (Ensure it is enabled)
Released for: Schneider Electric Saudi Arabia
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