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PMEHC 7.2.2 EPSS Report does not render correctly when selected date range is used as a report parameter instead of run historyIssue:
Issue:
In a PMEHC system, when running the EPSS report using the Run History as a report parameter, it generates the report correctly. However, when a date range covering more than one run is selected the "Generator and ATS Event Summary" section doesn't get populated correctly. The "Sources in EPSS Group" section will also be inaccurate and may only include sources from the last run in the selected date range.
Product Line:
Power Monitoring Expert for Health Care 7.2.2
Environment:
Power Monitoring Expert for Health Care 7.2.2 EPSS Report
Cause:
This is a problem with the EPSS Report in PMEHC 7.2.2 which Continuous Engineering is working on a hotfix for.
Resolution:
In the meantime, to resolve this issue the following steps need to be performed.
1. Navigate to the Power Monitoring Expert for Health Care folder. Within this folder, locate the system/ReportDataService/bin folder and make copies of the EPSS.Configuration.Business.dll and EPSS.View.Provider.dll.
2. Place copies of these two files in a backup folder located elsewhere
3. Overwrite the EPSS.View.Provider.dll file in the system/ReportDataService/bin folder with the attached EPSS.View.Provider.dll file
4. Overwrite the EPSS.Configuration.Business.dll with the attached EPSS.View.Provider.dll in the following locations within the Power Monitoring Expert for Health Care folder:
a. Applications/bin
b.system/bin
c.system/ReportDataService/bin
d.web/bin
In a PMEHC system, when running the EPSS report using the Run History as a report parameter, it generates the report correctly. However, when a date range covering more than one run is selected the "Generator and ATS Event Summary" section doesn't get populated correctly. The "Sources in EPSS Group" section will also be inaccurate and may only include sources from the last run in the selected date range.
Product Line:
Power Monitoring Expert for Health Care 7.2.2
Environment:
Power Monitoring Expert for Health Care 7.2.2 EPSS Report
Cause:
This is a problem with the EPSS Report in PMEHC 7.2.2 which Continuous Engineering is working on a hotfix for.
Resolution:
In the meantime, to resolve this issue the following steps need to be performed.
1. Navigate to the Power Monitoring Expert for Health Care folder. Within this folder, locate the system/ReportDataService/bin folder and make copies of the EPSS.Configuration.Business.dll and EPSS.View.Provider.dll.
2. Place copies of these two files in a backup folder located elsewhere
3. Overwrite the EPSS.View.Provider.dll file in the system/ReportDataService/bin folder with the attached EPSS.View.Provider.dll file
4. Overwrite the EPSS.Configuration.Business.dll with the attached EPSS.View.Provider.dll in the following locations within the Power Monitoring Expert for Health Care folder:
a. Applications/bin
b.system/bin
c.system/ReportDataService/bin
d.web/bin
Released for:Schneider Electric Saudi Arabia
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