Issue
Cannot connect to Sepam with the SFT2841 software
Product Line
Sepam series 20
Sepam series 40
Sepam series 80
Environment
SFT2841 software
Windows 10
Windows 7
Cause
With the SFT2841 software version V16.4, a certain version of the Schneider Electric Modbus Driver is included with the installation package. If it is necessary to troubleshoot the Modbus Driver installation, some additional work may be required.
An issue may arise in some cases because there are other software applications developed by Schneider Electric that use the same Modbus Driver component as the SFT2841 software, and in some cases, they may use different versions of this component compared to SFT2841.
Resolution
Please refer to FA279049 for initial steps to troubleshoot the connection to the Sepam unit
If your installation of the Sepam SFT2841 software V16.4 has completed without any error messages, but you still have problems connecting to your Sepam relay, you can try the following procedure.
Please contact the Sepam Technical Support if you are still having problems connecting to your relay.
For the latest version of SFT2841 please refer to FA180051.
Cannot connect to Sepam with the SFT2841 software
Product Line
Sepam series 20
Sepam series 40
Sepam series 80
Environment
SFT2841 software
Windows 10
Windows 7
Cause
With the SFT2841 software version V16.4, a certain version of the Schneider Electric Modbus Driver is included with the installation package. If it is necessary to troubleshoot the Modbus Driver installation, some additional work may be required.
An issue may arise in some cases because there are other software applications developed by Schneider Electric that use the same Modbus Driver component as the SFT2841 software, and in some cases, they may use different versions of this component compared to SFT2841.
Resolution
Please refer to FA279049 for initial steps to troubleshoot the connection to the Sepam unit
If your installation of the Sepam SFT2841 software V16.4 has completed without any error messages, but you still have problems connecting to your Sepam relay, you can try the following procedure.
- Access Windows Control Panel > Programs and Features > locate the DriverManager X64 and Modbus Driver X64
- Un-install the SFT2841 software
- Manually uninstall the DriverManager X64 and Modbus Driver X64 identified in Step 1
- Reboot your computer/laptop
- Run the SFT2841 V16.4 installer again. Alternatively, you can also use the BOX link below to download the Schneider Modbus Driver suite, which is current as of December 2018.
- To reach the BOX link click here.
- After a successful installation, one should see that the Modbus Driver has been installed again, and this version should be compatible with SFT2841
- Internet access may be needed for the DriverManager X64 to be updated to the computer/laptop
- With your PC connected to the Internet, update the Sepam Serial Port driver through Windows, as shown in the image below. Be sure that you wait until Windows has finished updating your Sepam Serial Port driver.
- One should now be able to connect to your Sepam device.
Please contact the Sepam Technical Support if you are still having problems connecting to your relay.
For the latest version of SFT2841 please refer to FA180051.