Issue:
After installing PowerChute Network Shutdown for an ESXi host, the PowerChute VM reports
“PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
Product:
PowerChute Network Shutdown versions 4.4.x, 5.x
Environment:
PowerChute Appliance/VM on a single ESXi host.
Cause:
The PowerChute web interface username and password are not set when the VM is installed.
Solution:
# Check for an ovf environment...
#vmtoolsd --cmd 'info-get guestinfo.ovfenv' > /dev/null 2>&1
#if [ $? -ne 0 ]; then
# echo -e "\n\nPowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.\n\n" >> /etc/issue
#fi
Next, edit the file /etc/motd. Delete all the lines and save the file.
After the next reboot when you log in, you will not see the error message “PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
NOTE: If you are not comfortable with using vi editor:
# Check for an ovf environment...
#vmtoolsd --cmd 'info-get guestinfo.ovfenv' > /dev/null 2>&1
#if [ $? -ne 0 ]; then
# echo -e "\n\nPowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.\n\n" >> /etc/issue
#fi
Next, edit the file /etc/motd. Delete the lines and save the file.
After the next reboot when you log in, you will not see the error message “PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
Released for: Schneider Electric Singapore
Issue:
After installing PowerChute Network Shutdown for an ESXi host, the PowerChute VM reports
“PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
Product:
PowerChute Network Shutdown versions 4.4.x, 5.x
Environment:
PowerChute Appliance/VM on a single ESXi host.
Cause:
The PowerChute web interface username and password are not set when the VM is installed.
Solution:
# Check for an ovf environment...
#vmtoolsd --cmd 'info-get guestinfo.ovfenv' > /dev/null 2>&1
#if [ $? -ne 0 ]; then
# echo -e "\n\nPowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.\n\n" >> /etc/issue
#fi
Next, edit the file /etc/motd. Delete all the lines and save the file.
After the next reboot when you log in, you will not see the error message “PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
NOTE: If you are not comfortable with using vi editor:
# Check for an ovf environment...
#vmtoolsd --cmd 'info-get guestinfo.ovfenv' > /dev/null 2>&1
#if [ $? -ne 0 ]; then
# echo -e "\n\nPowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.\n\n" >> /etc/issue
#fi
Next, edit the file /etc/motd. Delete the lines and save the file.
After the next reboot when you log in, you will not see the error message “PowerChute Services are disabled due to invalid credentials. Please refer to the PowerChute User Guide for recovery procedures.”
Released for: Schneider Electric Singapore




Need help?
Start here!
Find answers now. Search for a solution on your own, or connect with one of our experts.
Contact Support
Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.
Where to buy?
Easily find the nearest Schneider Electric distributor in your location.
Search FAQs
Search topic-related frequently asked questions to find answers you need.
Contact Sales
Start your sales enquiry online and an expert will connect with you.