我们今天能为您提供什么帮助?

Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?

Issue

Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?

Product Line

Struxureware Power Monitoring 7.0(SPM)

Power Monitoring Expert 7.2.x

Power Monitoring Expert 8.x

Power Monitoring Expert 9.0

Cause

RegBrick_x86.msi is a third party component that is used by PME. It is sometimes flagged by anti-virus software (McAfee for sure and possibly other anti-virus programs) as a Trojan and so it gets moved by the anti-virus software to a quarantine folder.
Part of the PME upgrade process is to uninstall the old msi packages prior to installing the newer versions. Because the RegBrick_x86 information has been removed from its expected location, the PME installer is unable to proceed and pops up a dialog (see attached screen cap)


Resolution
Recommended workaround
Browse to the Microsoft link below:

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

Download the 'Program Install and Uninstall Troubleshooter' tool and save it locally.
Run the tool and choose 'RegBrick_x86' from the list of programs that will be presented (see attached screen cap)
Then click on 'Yes, try uninstall' (see attached screen cap)
Once this has been done, the PME upgrade will proceed without this problem.

Another Workaround
You will need the iso from the version of PME that you are upgrading from. If you have that, when the popup dialog appears, browse the iso to RegBrick_x86.msi. It can be found in the \setup\installers folder on the iso. Note that you need the exact version of RegBrick_x86.msi that corresponds to the version you are upgrading from.

Additional Information
The Registration Brick component is being removed for Power Monitoring Expert 9.0. If older PME systems are upgraded to PME 9.0, the Registration Brick component does not get uninstalled, but this will not cause any problems. If desired, it is possible to remove this orphaned component by following the steps above.


施耐德電機Taiwan

附件
RegBrick_Tool_Program_list.png [16.28 KB]
RegBrick_popup.png [8.36 KB]
RegBrick_tool_uninstall.png [11.84 KB]
探索更多
產品:
探索更多
產品:

需要協助?

需要協助?

產品選型工具

產品選型工具

快速輕鬆地為您的應用找到合適的產品和附件。

取得報價

取得報價

立即線上提交您的銷售需求,專業團隊將主動聯繫您。

購買地點

購買地點

輕鬆在您所在地區找到最近的施耐德電機經銷商。

支援中心

支援中心

在同一位置找到滿足您所有需求的支援資源。

  • 產品文檔
  • 軟體下載
  • 產品選型工具
  • 產品替代和替換
  • 幫助和聯絡中心
  • 尋找我們的辦公室
  • 取得報價
  • 施耐德電機社群
  • 人才招募
  • 公司簡介
  • 舉報不當行為
  • 無障礙
  • 新聞中心
  • 投資者
  • 專業洞察
  • 台灣施耐德電機學院
  • 綠色影響力落差調查
  • Schneider Go Green 2025
  • 隱私政策
  • Cookie通告
  • 使用條款
  • Change your cookie settings