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Restoring VIP
Issue:
VIP has been deleted or corrupted. Designer has unassociated modules from their programs and is grouped by module type rather than defined grouping objects i.e. "Arithmetic Modules", "Data Recorder Modules" etc.

Product Line:
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment:
Designer
Diagnostics Tool

Cause:
This can happen when a VIP configuration file has become damaged, corrupted, or unassociated with the folder it is inside. This can happen as a result of incorrectly changing the VIP folder name by changing the folder name in File Explorer.

Resolution:
VIP backup files are taken with each diagnostic. Navigate to a previously taken diagnostic and restore the files with the following process.

Note: This will only work to restore the VIP to a previous backup from the Diagnostics file.
  • Navigate to a previous Diagnostics cab file. Unzip. Diagnostics File -> Outputs -> VIP files.
  • Copy vip."name".bak, vip."name".cfg and vip."name".nd.cfg.
  • Stop all ION services.
  • Navigate to ...Schneider Electric\Power Monitoring Expert\config\cfg\vip. Copy the vip.cfg and vip.bak files associated with the VIP you want to restore. Store them in a safe location.
  • Delete the vip.bak and vip.cfg from the folder.
  • Navigate to ...Schneider Electric\Power Monitoring Expert\config\diagrams\nd. Copy the vip.cfg. Store in a safe location.
  • Delete the vip.cfg from the folder.
  • Copy the old vip.cfg and vip.bak files into the associated VIP folder. Rename to match naming convention. "vip.cfg" and "vip.bak"
  • Copy the old diagram vip.cfg into the associated diagram folder. Rename to match naming convention. "vip.'vipname'.cfg".
  • Restart all services.
  • Verify program has returned to its previous state in Designer.

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