PME - User Manager shows "Unable to get user data due to the following code: 400 Bad Request"
Issue
User Manager displays an error message "Unable To Get User Data" with code "400 error" or "400 Bad Request":
The system log displays the error: "This constraint cannot be enabled as not all values have corresponding parent values."
Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Web Applications
User Manager
Cause
A conflict in the database prevents User Manager from populating the list of users.
Resolution
Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.
1. Open SQL Server Management Studio and connect to the PME SQL Server.
2. Execute the following script:
DELETE FROM [ION_Network].[dbo].[GroupMembershipMap]
WHERE TrusteeID NOT IN (SELECT UserID FROM [ION_Network].[dbo].[Users])
3. Refresh the Web Applications.
發佈於: 施耐德電機Taiwan
需要協助?
產品選型工具
快速輕鬆地為您的應用找到合適的產品和附件。
取得報價
立即線上提交您的銷售需求,專業團隊將主動聯繫您。
購買地點
輕鬆在您所在地區找到最近的施耐德電機經銷商。
支援中心
在同一位置找到滿足您所有需求的支援資源。