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Power Monitoring Expert (PME) Device Type shows "137"/arbitrary number in Management Console

Issue

In Power Monitoring Expert (PME) Management Console application, the device type shows a number (typically 137 if it is a custom device) rather than the correct device type name.


Product line

Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Power Monitoring Expert 2024


Environment
PME Web Application

SQL Server Management Studio (SSMS)

Cause

The most common cause of this is when a device has ethernet support and is added to the system, but due to human/software error the device type loses its ethernet support. So when adding a new ethernet device, the device type does not display correctly and instead shows a number -- the number is the "device type ID" that is associated with the device type in the PME SQL ION_Network database.


Resolution

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

  1. Use the below query, replacing the "DeviceDisplayName" with the intended device display name, if you remember it. If you do not, you can enter the name you expect and look for the correct name in the results. The correct name will be in the column
    Select * FROM [ION_Network].[dbo].[DeviceType] where DisplayName LIKE 'ÞviceDisplayName%'
  2. Check the column "EthernetSupport" to see if it is a 0 or 1. If the issue is being seen, the expected value here is 0 (false).
  3. Update the value to a 1 (true). Replace 'DeviceDisplayName' with the exact DisplayName you found in the previous step.
USE ION_Network;
GO
UPDATE dbo.Devicetype
SET EthernetSupport = 1
WHERE DisplayName = 'DeviceDisplayName'

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