What causes the error "Insert the external storage previously used ..." on a HMI running EOTE and how to solve it?
Issue
One of the following error messages are displayed on an HMI configured with EOTE after the external storage (USB or SD card) is removed.
Message 1
Insert the external storage previously used as the [Save in] destination and restart the panel.
If the same external storage is unavailable, recover using the project transfer command.
Message 2
A fatal error occurred.
External Storage used as Backup Memory (SRAM) is unavailable.
Insert external storage and restart the panel.
Product Line
EcoStruxure Operator Terminal Expert (EOTE)
Environment
HMIs programmed with EOTE
Cause
The HMI is actively using the external storage (USB or SD card) as part of its runtime data handling. If that storage is removed while the HMI is powered on, the system loses access to critical data. This typically happens when any of the features mentioned below are configured to save directly to external storage.
-All Alarms
-Operation Log
-All Loggings
Removing it interrupts normal operation and triggers a fault message.
Resolution
The external storage needs to be plugged back into the HMI and then click reset. If this is not possible, the project will need to be re-downloaded into the HMI.
For future consideration, these options are available:
Option 1: Keep the external storage connected
-Do not remove the USB or SD card while the HMI is powered on.
-Treat the external storage as part of the system when it is selected as a storage destination.
-EOTE provides a warning during configuration when logs are saved to external storage. Pay attention to this warning and plan accordingly.
Option 2) Use internal Backup Memory instead
Change the "Save in" setting for:
-All Alarms
-Operation Log
-All Loggings
To "Backup Memory" instead of external storage. This keeps data available even if no USB or SD card is inserted.
Picture for reference:
A Script can be used to Export the data into a USB stick.
Example script for reference:
If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.
If you are not located in North America, please contact your local Customer Care Center for assistance:
Support | Schneider Electric Global (se.com)
發佈於: 施耐德電機Taiwan
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