How can we help you today?

PME - Power Quality Report returns no data when run against an archive database

Issue
When running a Power Quality Report in PME version 8.2 and up, no data is returned despite there being known power quality events logged in the database. The System Log Events in Management Console shows an error such as "Failed to update database "ION_Data_Archive" because the database is read-only."

PQ report no data

Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.0
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023

Environment
Web Applications Reports

Cause
The Power Quality Report is unable to populate data when querying an ION_Data archive that is set to Read-Only.

Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by
users familiar with SQL Server Management Studio. Databases should be backed up prior to
performing this procedure.*


The ION_Data archive must be set to Read-Write.
  1. Open SQL Server Management Studio (SSMS), then connect to the PME database instance (default is ION)
  2. Expand Databases, then Right-Click the ION_Data archive database
  3. Select Properties > Options
  4. Scroll to the bottom of the list where it says 'State', then change 'Database Read-Only' to 'False'.
Read-write set to false

Schneider Electric USA

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:

Need help?

Need help?

Product Selector

Product Selector

Quickly and easily find the right products and accessories for your applications.

Get a Quote

Get a Quote

Start your sales inquiry online and an expert will connect with you.

Where to buy?

Where to buy?

Easily find the nearest Schneider Electric distributor in your location.

Help Center

Help Center

Find support resources for all your needs, in one place.

  • Help and Contact Center
  • Contact Sales
  • Find our Offices
  • Where to Buy
  • Tech Support: 877-342-5173
  • Careers
  • Company Profile
  • Investors
  • Newsroom
  • Report a Misconduct
  • Product Documentation
  • Software and Firmware
  • Product Selector
  • Product Replacement
  • DigestPLUS Online Catalogue
  • Blog
  • Events
  • Schneider Electric Community
  • Sustainability
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings