Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
		
How can we help you today?
You are currently viewing the content available in Vietnam. If you are looking for information for another region, please select the correct country from the top-left dropdown in the page and 'Navigate to Browse FAQs' in the Support menu.
PME 9.0 - LogSubSystem services won't start
Issue
After upgrading/migrating the system or a fresh installation the installer will fail at "Start Services" and "Verify Registered Service" at the final stage. It will state that the PMLOGROUTER exceeded the timeout of 300 seconds.
PMLOGROUTER refers to LogSubSystem service.

Product Line
Power Monitoring Expert  9.0 (including with the CU1 applied)

Environment
Upgrade - Migration - New Installation for PME 9.0

Cause
The LogSubSystem service will fail to create the Message Queues under Computer Management > Services and Application > Message Queuing > Private Queues due to the server name being longer than 15 characters - therefore the service will not start and no data will be logged into the database.

When trying to unregister this service and register it back again through the command prompt, it will give the following error message:
Could not create primary data router message queues: Could not initialize standard queues for Queue: LogSubsystemPrimaryRouter@STANDALONE-TEST-PME: Could not create queue: ("STANDALONE-TEST-PME\private$\LogSubsystemPrimaryRouter_Data", "") at step check exists: Invalid queue path name.; ErrorCode: [IllegalQueuePathName]. The router will attempt to create the queues each time it starts.

PME has always worked as expected in the previous version because it uses the NetBIOS name of the computer, which is limited to 15 bytes, however, this service has been introduced in PME 9.0 and it will use the full name as it uses Microsoft Message Queueing.

Resolution
The PME 9.0 - System Guide is very specific regarding the PME Serve Name Limitations (page 51 - Other IT Considerations), where it states that the computer name for the PME server MUST have 15 characters or less, and use only letters, numbers, or the "_" character.

Please follow the steps:
1- Check the server name: Open SSMS > ION_Network > dbo.Machine
2- Rename the server (in System Properties > Computer Name/Domain Changes > Computer Name) to MATCH the name found in the database - THIS IS VERY IMPORTANT - It has to be the same otherwise the system won't work.
3- Reboot the server
4- Logged as administrator, open the command prompt
Run the command to remove the service:
LogSubsystem.Service.exe -UnregServer
Run the command to add the service back:
LogSubsystem.Service.exe -Service
5 - Go to Computer Management > Services and Application > Message Queuing > Private Queues and check if the queues referring to this service were created
6 - Start the LogSubSystem service under Windows Service

Applying the CU1 will NOT fix the issue.
Although this specific server will fail to start, PME database will use the NetBios shortened to 15 bytes - so the system will work normally if the server name matches the one found in the databases.

Schneider Electric Vietnam

Explore more
Range:
Users group

Discuss this topic with experts

Visit our community and get advice from experts and peers on this topic and more
Explore more
Range:

Need help?

  • Start here!

    Find answers now. Search for a solution on your own, or connect with one of our experts.

  • Contact Support

    Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.

  • Where to buy?

    Easily find the nearest Schneider Electric distributor in your location.

  • Search FAQs

    Search topic-related frequently asked questions to find answers you need.

  • Contact Sales

    Start your sales inquiry online and an expert will connect with you.

I'd like to receive news and commercial info from Schneider Electric and its affiliates via electronic communication means such as email, and I agree to the collection of information on the opening and clicks on these emails (using invisible pixels in the images), to measure performance of our communications and improve them. For more details, please read our Privacy Policy.

  • Products Documentation
  • Software Downloads
  • Product Selector
  • Product Substitution and Replacement
  • Help and Contact Center
  • Find our Offices
  • Get a Quote
  • Where to buy
  • Company Profile
  • Report a misconduct
  • Accessibility
  • Investors
  • EcoStruxure
  • Job Search
  • Blog
  • Privacy Policy
  • Cookie Notice
  • Terms of use
  • Change your cookie settings