Nhãn hiệu của chúng tôi

Impact-Company-Logo-English Black-01-177x54

Chào mừng bạn đến với Trang web của Schneider Electric

Chào mừng đến với trang web của chúng tôi.
		
Hôm nay chúng tôi có thể giúp gì cho bạn?
Could not write to Event log pipeline in Alarm Service." after upgrading PME

Issue
Events from devices and Software Alarms don't show up in Alarms and are not written to the database.


Example of the error message in the  System Log:

ID: 3367495

Timestamp: 13/02/2020 9:40:38,107

Priority: ERROR

Source: Software Data Processing Service

Target: EventLogWriter

Category: Computer General

Computer: COMPUTERNAME

Description: Could not write to Event log pipeline in Alarm Service.

ID: 3367494

Timestamp: 13/02/2020 9:40:38,087

Priority: ERROR

Source: Software Data Processing Service

Target: LogAcquisitionMessenger

Category: Computer General

Computer: COMPUTERNAME

Description: Message Write Failure: Error sending message on queue '.\private$\LogSubsystemPrimaryRouter_Data'.; ErrorCode: [AccessDenied]; Body: DataMessage: Operation [Insert]; Filtered [False] Retry [0]



Product Line
Power Monitoring Expert 7.2.2
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024

Environment
PME Web Application

Alarms



Cause
The ION Log Subsystem Router Service is running under a user that does not have access to the message queues or the message queues were not built correctly.

Resolution
Confirm that the user permissions for the Log Subsystem Router Service is allowed access cloudagent_control, cloudagent_data, logsubsystemprimaryrouter_control, logsubsystemprimaryrouter_data, logsubsystemsecondaryrouter_control, logsubsystemsecondaryrouter_data Private Queues.

  1. Open Computer Management on the PME Server.
  2. Open Services and Applications > Message Queuing > Private Queues

example of message queues

  1. Right click on each of the 6 queues, select Properties, and open the Security tab.
  2. Confirm each of these queues permissions:
    1. "Everyone" group has access to allow:
      • Get Properties
      • Get Permissions
      • Send Message
    2. "LOCAL SERVICE" or if applicable, the user set to run the "ION Log Subsystem Router Service", should have full access to the queue
      • Full Access
    3. "ANONYMOUS LOGON" group should only have access to:
      • Send Message

If adding everyone does not solve the issue then recreate the queues:

  1. Stop all PME services
  2. Delete the 6 message queues
  3. Start the Network Router Service
  4. Start Log Inserter Service
  5. Start the Log Subsystem Router Service
  6. Start all other PME services

Schneider Electric Việt Nam

Tìm hiểu thêm
Phạm vi:
Tìm hiểu thêm
Phạm vi:

Bạn cần trợ giúp?

  • Công cụ chọn sản phẩm

    Nhanh chóng và dễ dàng tìm được sản phẩm và phụ kiện phù hợp cho các ứng dụng của bạn.

  • Nhận báo giá

    Bắt đầu gửi yêu cầu bán hàng trực tuyến và chuyên gia sẽ liên hệ với bạn.

  • Nơi mua hàng?

    Dễ dàng tìm nhà phân phối Schneider Electric gần bạn nhất.

  • Trung tâm Hỗ trợ

    Tìm sự hỗ trợ cho mọi nhu cầu của bạn tại một nơi.

  • Tài liệu về Sản phẩm
  • Tải xuống phần mềm
  • Công cụ chọn Sản phẩm
  • Thay thế và thay đổi sản phẩm
  • Trung tâm Hỗ trợ
  • Tìm Văn phòng của chúng tôi
  • Nhận báo giá
  • Tìm Nhà Phân phối
  • Cơ hội nghề nghiệp
  • Hồ sơ doanh nghiệp
  • Báo cáo hành vi sai trái
  • Khả năng truy cập
  • Phòng tin tức
  • Nhà đầu tư
  • EcoStruxure
  • Tìm việc
  • Blog
  • Chính sách bảo mật
  • Thông báo về Cookie
  • Điều khoản sử dụng
  • Change your cookie settings