What is the claims procedure for residential SPDs?
Issue:
How do I file a claim for residential surge protection devices (SPDs)?
Product Line:
Surge Protection Devices
Environment:
Maintenance
Cause:
Device Failure Equipment Protection Plan (EPP)
Resolution:
Claims Procedure
To submit a claim under this limited warranty, please follow these steps:
-
Keep Your Receipt
Retain the original dated sales receipt for the Home Electronics Protective Device (HEPD). -
Obtain a Damage Report
Have an independent repair technician assess the damage and provide a written report detailing the cause. Keep this report along with any related repair receipts. -
File a Homeowner’s Insurance Claim
Submit a claim through your homeowner’s insurance policy. -
Contact Schneider Electric
Within 30 days of the damage—and before repairing the damaged equipment—contact Schneider Electric at (800) 877-1174.
Hours:- Monday–Thursday: 7:00 a.m. – 5:00 p.m. CT
- Friday: 7:00 a.m. – 1:00 p.m. CT
-
Submit Documentation and Device
Send the following items to the address below:- Original purchase receipt
- Repair receipt(s)
- Damage report
- Homeowner’s insurance claim report (if available)
- The damaged HEPD unit
Mail to:
Schneider Electric
132 Fairgrounds Rd
West Kingston, RI 02892
Attn: Residential SPD Limited Warranty
Released for: Schneider Electric Canada










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