Jak vám dnes můžeme pomoci?

Why do I get the dialog message Application has halted due to: Unhandled, java/lang/NullPointerException IVM: except.c: line 322 on a Magelis HMI?

Issue
Why do I get the dialog message "Application has halted due to: Unhandled, java/lang/NullPointerException IVM: except.c: line 322" on a Magelis HMI?
How do I avoid the message?

Product Line
Vijeo Designer, Magelis HMI

Environment
Physical HMI, Vijeo Designer configuration software on Windows

Cause
The NullPointerException errors are usually associated with the SRAM data being corrupted. If there are changes in a project with Alarms, Logging, Retentive variables configuration, Recipes, Security Settings, or Target System settings, and then the new project is downloaded to the HMI without clearing the SRAM, old data (that will now be orphaned) in the SRAM (when the HMI attempts to read from it during operation) can cause this error.

Also, if  the system has frequent unscheduled power outages and it cannot use the System Operation "Exit Runtime" before shutdown of the HMI, it is recommended that a UPS battery backup be used for the HMI as the SRAM may be mid-write when the power-failure occurs and have incomplete/orphaned data accumulate over time.

Resolution
After changing an existing project in Vijeo Designer and on a subsequent download to a Magelis HMI, ensure you choose "Delete All Run-Time Data" when prompted.
You can also find this setting when you click "Preserve Run-Time Data" in the Target General settings when editing the project.

Schneider Electric Česká republika

Zjistěte více
Řada:
Zjistěte více
Řada:

Potřebujete pomoc?

Potřebujete pomoc?

Nástroj pro výběr produktů

Nástroj pro výběr produktů

Rychle a snadno vyhledávejte správné produkty a příslušenství pro vaše aplikace.

Získejte nabídku

Získejte nabídku

Poptejte se nás online a náš lokální specialista se s vámi spojí!

Kde nakoupit?

Kde nakoupit?

Jednoduše najděte nejbližšího distributora výrobků Schneider Electric ve vašem okolí.

Centrum nápovědy

Centrum nápovědy

Zdroje podpory pro všechny své potřeby najdete na jednom místě.

  • Dokumentace k produktům
  • Software ke stažení
  • Nástroj pro výběr produktů
  • Hledání náhrady za produkty
  • Centrum nápovědy a kontakty
  • Najít naše pobočky
  • Získejte nabídku
  • Kde koupit
  • Komunita Schneider Electric
  • Kariéra
  • Profil společnosti
  • Nahlásit nevhodné chování
  • Přístupnost
  • Newsroom
  • Investoři
  • EcoStruxure
  • Vyhledávání pracovních míst
  • Blog
  • Zásady ochrany osobních údajů
  • Oznámení o souborech cookie
  • Podmínky použití
  • Změnit nastavení souborů cookie